hdu5606(并查集)

There is a tree(the tree is a connected graph which contains nn points and n−1n−1edges),the points are labeled from 1 to nn,which edge has a weight from 0 to 1,for every point i∈[1,n]i∈[1,n],you should find the number of the points which are closest to it,the clostest points can contain ii itself. 

Input

the first line contains a number T,means T test cases. 

for each test case,the first line is a nubmer nn,means the number of the points,next n-1 lines,each line contains three numbers u,v,wu,v,w,which shows an edge and its weight. 

T≤50,n≤105,u,v∈[1,n],w∈[0,1]T≤50,n≤105,u,v∈[1,n],w∈[0,1]

Output

for each test case,you need to print the answer to each point. 

in consideration of the large output,imagine ansiansi is the answer to point ii,you only need to output,ans1 xor ans2 xor ans3.. ansnans1 xor ans2 xor ans3.. ansn. 

Sample Input

1
3
1 2 0
2 3 1

Sample Output

1

in the sample.

$ans_1=2$

$ans_2=2$

$ans_3=1$

$2~xor~2~xor~1=1$,so you need to output 1.

题意:

有一棵树(树是一个包含n个点和n-1个边的连通图),这些点从1到n标记,该边的权重从0到1,对于每个点i∈[1,n ],你应该找到最接近它的点的数量,clostest点可以包含我自己。
输入
第一行包含数字T,表示T测试用例。

对于每个测试用例,第一行是nubmer n,表示点的数量,接下来是n-1行,每行包含三个数字u,v,w,它们显示边缘及其权重。
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;

int pre[1000003];
int num[1000003];
int find(int x)
{
    return x==pre[x]?x:pre[x]=find(pre[x] );
}
void join(int x,int y)
{
    int a=find(x);
    int b=find(y);
    if(a!=b)
    {
        pre[a]=b;
        num[b]+=num[a];//这里就是把子节点的都加到父节点上,找到每一个联通快中的任意点,
直接找到祖先的嘴短点的数目就行了。
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=100003;i++)
            pre[i]=i,num[i]=1;
        for(int i=1; i<n; i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            if(c==0)
            {
                join(a,b);
            }
        }
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            ans^=num[find(i)];//每一个联通快中的点,都是到这个联通块的点的最短的点。
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值