The Pilots Brothers' refrigerator

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23708 Accepted: 9132 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4
这个题试了一下状态压缩BFS果然是超时。

这个题就直接仿照filp game解决即可。每次也是只有改变和不改变两种状态。改变的顺序对最后的状态是没有影响的,所以从头搜到尾一次即可。

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int tu[4][4];
int x[20];
int y[20];

int ansx[20];
int ansy[20];
int ans = 20;

void in()
{
    char t[4][5];
    int i,j;
    for(i=0;i<4;++i)
    {
        scanf("%s",t[i]);
    }
    for(i=0;i<4;++i)
    {
        for(j=0;j<4;++j)
        if(t[i][j]=='+')tu[i][j]=1;
        else tu[i][j]=0;
    }
}

void change(int s)
{
    int x = s/4;
    int y = s%4;
    for(int i = 0; i < 4; i++)
    {
        tu[i][y] = !tu[i][y];
        tu[x][i] = !tu[x][i];
    }
    tu[x][y] = !tu[x][y];
}

bool panduan()
{
    for(int i = 0; i < 4; i++)
    {
        for(int j = 0; j < 4; j++)
            if(tu[i][j] == 1) return 0;
    }
    return 1;
}

void dfs(int s, int sum)
{
    if(panduan())
    {
        if(ans > sum)
        {
            ans = sum;
            for(int i = 0; i < ans; i++)
            {
                ansx[i] = x[i];
                ansy[i] = y[i];
            }
        }
        return;
    }

    if(s >= 15) return;
    dfs(s+1, sum);
    change(s+1);
    x[sum] = (s+1)/4+1;
    y[sum] = (s+1)%4+1;
    dfs(s+1, sum+1);
    change(s+1);
}

int main()
{
    in();
    dfs(-1, 0);
    printf("%d\n",ans);
    int i;
    for(i=0;i<ans;++i)
    {
        printf("%d %d\n",ansx[i],ansy[i]);
    }
    return 0;
}

借鉴了一下储存路径,要在新操作之后临时记录,最后符合条件记录到最终结果里。

贴一下神牛的做法:以下为转载

参考高手的高效解法:
证明:要使一个为'+'的符号变为'-',必须其相应的行和列的操作数为奇数;可以证明,如果'+'位置对应的行和列上每一个位置都进行一次操作,则整个图只有这一'+'位置的符号改变,其余都不会改变.
 那么可以设置一个4*4的整型数组,初值为零,用于记录每个点的操作数,那么在每个'+'上的行和列的的位置都加1,得到结果模2(因为一个点进行偶数次操作的效果和没进行操作一样,这就是楼上说的取反的原理),然后计算整型数组中一的
 个数即为操作数,一的位置为要操作的位置(其他原来操作数为偶数的因为操作并不发生效果,因此不进行操作)
*********************************
此上证其可以按以上步骤使数组中值都为‘-’
********************************
在上述证明中将所有的行和列的位置都加1后,在将其模2之前,对给定的数组状态,将所有的位置操作其所存的操作数个次数,举例,如果a[i][j]==n,则对(i,j)操作n次,当所有的操作完后,即全为‘-’的数组。
其实就是不模2的操作,作了许多的无用功。//上面也已经说过最多每个点改变一次
以上的操作次序对结果无影响,如果存在一个最小的步骤,则此步骤一定在以上操作之中。
而模2后的操作是去掉了所有无用功之后的操作,此操作同样包含最小步骤。
但模2后的操作去掉任何一个或几个步骤后,都不可能再得到全为‘-’的。(此同样可证明:因为操作次序无影响,先进行最小步骤,得到全为‘-’,如果还剩下m步,则在全为‘-’的数组状态下进行这m步操作后还得到一个全为
‘-’的数组状态,此只能是在同一个位置进行偶数次操作,与前文模2后矛盾,所以m=0),因此模2后的操作即为最小步骤的操作。
*/
#include <iostream>
using namespace std;

bool mark[4][4];
char s[4][4];

int main()
{
    int i,j,k;
    int ci[16],cj[16];
    int nas = 0;
    memset(mark,0,sizeof(mark));
	for(i = 0;i < 4;i++)
		cin >> s[i];
    for(i = 0;i < 4;i++)
        for(j = 0;j < 4;j++)
        {
            char c = s[i][j];
            if(c == '+')
            {
                mark[i][j] = !mark[i][j];//这个地方以及下面就相当于+1模2
                for(k = 0;k < 4;k++)
                {
                    mark[i][k] = !mark[i][k];
                    mark[k][j] = !mark[k][j];
                }
            }

        }
    for(i = 0;i < 4;i++)
        for(j = 0;j < 4;j++)
            if(mark[i][j] == true)
            {
                ci[nas] = i + 1;
                cj[nas] = j + 1;
                nas ++;
            }
    printf("%d\n",nas);
    for(i = 0;i < nas;i++)
    {
        printf("%d %d\n",ci[i],cj[i]);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值