poj3009 Curling 2.0

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17782 Accepted: 7315

Description

On Planet MM-21, after their Olympic games this year, curling(卷曲) is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a squaremesh(网眼) is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum(最小的) number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied(占据) with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct(明显的).) Once the stone begins to move, it will proceed(开始) until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal(斜的) moves are prohibited(阻止).
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum(最小的) number of moves required.

With the initial configuration(配置) shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route(路线) is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution(解决方案) for Fig. D-1 and the final board configuration

Input

The input(投入) is a sequence(序列) of datasets. The end of the input is indicated(表明) by a line containing two zeros separated by a space. The number of datasets never exceeds(超过) 100.

Each dataset is formatted(格式化) as follows.

the width(=w) and the height(=h) of the board 
First row of the board 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal(小数) numbers delimited(划界) by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal(小数的) integer(整数) indicating(表明) the minimum(最小的) number of moves along a route(路线) from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

我的天又是看了好长时间的题目,搜了一下意思才终于明白到底是怎么走的。

给你一个m*n的地图,0表示空地,1表示障碍,2表示起始点,3表示终点。

每次只能向临近的没有障碍的点走,每次移动只要没碰到障碍就会一直继续走下去,除非离开边界,或者碰到障碍才会停下。当然如果你碰到了终点那么直接更新步数返回就可以了。

剩下的在代码里说吧(╯‵□′)╯︵┻━┻

#include <iostream>
#include <stdio.h>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <vector>
using namespace std;
const int MAXN=20+5;
const int inf=0x3f3f3f;
int n,m;
int sx,sy;
int tu[MAXN][MAXN];

int flag,ans;

void dfs(int sx,int sy,int step)
{
    int i=sx,j=sy;
    if(step>10||step>=ans)return ;
    //向上走
    if(--i>=0&&tu[i][j]!=1)                          //上面这个格如果可以走
    {
        while(i>=0&&tu[i][j]==0)--i;            //如果是空地就要一直走下去
        if(i>=0)                                           //如果不是飞出去了,飞出去直接继续下一个方向就可以了
        {
            if(tu[i][j]==3)                           //如果是到达了终点
            {
                ans=min(ans,step);
                return ;
            }
            else if(tu[i][j]==1)                        //如果碰到了障碍
            {
                tu[i][j]=0;//消除障碍
                dfs(i+1,j,step+1);//注意是从障碍上面那个点开始
                tu[i][j]=1;//这个别忘了返回

            }
        }
    }
    i=sx;
    j=sy;
    //向左走
    if(--j>=0&&tu[i][j]!=1)
    {
        while(j>=0&&tu[i][j]==0)--j;
        if(j>=0)
        {
            if(tu[i][j]==3)
            {
                ans=min(ans,step);
                return ;
            }
            else if(tu[i][j]==1)
            {
                tu[i][j]=0;
                dfs(i,j+1,step+1);
                tu[i][j]=1;
            }
        }
    }
    i=sx;
    j=sy;
    //向下走
    if(++i<n&&tu[i][j]!=1)
    {
        while(i<n&&tu[i][j]==0)++i;
        if(i<n)
        {
            if(tu[i][j]==3)
            {
                ans=min(ans,step);
                return ;
            }
            else if(tu[i][j]==1)
            {
                tu[i][j]=0;
                dfs(i-1,j,step+1);
                tu[i][j]=1;
            }
        }
    }
    i=sx;
    j=sy;
    //向右走
    if(++j<m&&tu[i][j]!=1)
    {
        while(j<m&&tu[i][j]==0)++j;
        if(j<m)
        {
            if(tu[i][j]==3)
            {
                ans=min(ans,step);
                return ;
            }
            else if(tu[i][j]==1)
            {
                tu[i][j]=0;
                dfs(i,j-1,step+1);
                tu[i][j]=1;
            }
        }
    }
}


int main()
{
    int i,j;
    while(~scanf("%d%d",&m,&n))
    {
        if(!m&&!n)break;
        for(i=0; i<n; ++i)
            for(j=0; j<m; ++j)
            {
                scanf("%d",&tu[i][j]);
                if(tu[i][j]==2)
                {
                    sx=i;
                    sy=j;
                }
            }
        ans=inf;
        flag=0;
        tu[sx][sy]=0;//起始点做0处理,这地方当然也是可以走的!和0没有区别
        dfs(sx,sy,1);
        if(ans==inf)puts("-1");//没更新过,自然就是没到达过终点
        else
            printf("%d\n",ans);
    }
    return 0;
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值