poj1080 Human Gene Functions

Human Gene Functions
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 18886 Accepted: 10518

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. 
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. 
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity 
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of 
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal 
length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix. 

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the 
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

题意:给你一个表,里面分别是两个字符匹配能够获得的值。现在给你两个字符串序列,你可以在两个串补字符‘-’,使得两个字符串一样长,问你可以得到的最大匹配值是多少。表示一开始没有什么思路,但是觉得应该是从最长公共子序列下手,但是完全不知道怎么联系,弄了一上午还是没什么可行的方法QAQ我就只好去依靠前辈了qwq。

思路:依旧看做是两个字符串匹配问题,只不过这次,我们的序列可以加长,对于每个新的i,j  每次状态有3个:

1:s1[i]和s2[j]匹配,此时获得的值就是dp[i-1][j-1]+match[s1[i]][s2[j]]。(match数组用来记录表格,也就是各种字符匹配的值)

2:s1[i]和s2[j-1]匹配,此时获得的值就是dp[i][j-1]+match['-'][s2[j]].(如果s1[i]是和s2[j-1]匹配的,那么s2[j]肯定只能和‘-’匹配了)(什么?你说还可以跟s1[i+1]匹配?我们每次都是列举相当于串长i,j的,而且这样做想想是不是就是这个状态?会不会跟下一个重复?)

3:s1[i-1]和s2[j]匹配,此时获得的值就是dp[i-1][j]+match[s1[i]]['-'].

所以dp[i][j]的值就是这3种状态里面最大的值了。

做dp的题就是要找准所有可能的状态,每次从每种更新的状态里面选取最优解,最后得出结果。

总的来说就是感于推倒猜测公式!qwq

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
using namespace std;
const int MAXN=100+10;
const int inf=0x3f3f3f;
char s1[MAXN],s2[MAXN];
int match[MAXN][MAXN];
int dp[MAXN][MAXN];
void in()
{
    match['A']['A']=match['C']['C']=match['G']['G']=match['T']['T']=5;
    match['C']['A']=match['A']['C']=match['A']['T']=match['T']['A']=-1;
    match['T']['-']=match['-']['T']=-1;
    match['A']['G']=match['G']['A']=match['C']['T']=match['T']['C']=-2;
    match['G']['T']=match['T']['G']=match['G']['-']=match['-']['G']=-2;
    match['A']['-']=match['C']['G']=match['G']['C']=match['-']['A']=-3;
    match['C']['-']=match['-']['C']=-4;
}
int main()
{
    in();
    int t,i,j,l1,l2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%s",&l1,s1+1);
        scanf("%d%s",&l2,s2+1);
        dp[0][0]=0;
        for(i=1;i<=l1;++i)
        {
            dp[i][0]=dp[i-1][0]+match[s1[i]]['-'];
        }
        for(i=1;i<=l2;++i)
        {
            dp[0][i]=dp[0][i-1]+match['-'][s2[i]];
        }
        for(i=1;i<=l1;++i)
            for(j=1;j<=l2;++j)
        {
            dp[i][j]=max(dp[i-1][j]+match[s1[i]]['-'],dp[i][j-1]+match['-'][s2[j]]);
            dp[i][j]=max(dp[i][j],dp[i-1][j-1]+match[s1[i]][s2[j]]);
        }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}





  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值