POJ 3268 Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requiresTi (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  Ai, Bi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:给你n个牛,编号1~n然后有m条单向路,然后给你一个关键点x。问你这n头牛中到x再从x回来的最短路中最长的一条是多少。

x到各头牛的最短路很好求。

关键是各头牛到x的最短路,想着这里面肯定有某种联系,毕竟只要求出各头牛到x的最短路就行了,想着肯定跟x到各头牛的最短路有关,把图反过来,就变成了x到各头牛的最短路了。

所以下一步,把图的单向边路径箭头反向,求一次x到各头牛的最短路,最后i加起来看看哪个更大就好了。

#include <cstdio>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXN=1e5+7;
const int inf =1e9;
int n,m,x;
struct node
{
    int v;
    int w;
};
vector<node>G[MAXN];
vector<node>G1[MAXN];
int q[1005];
int dis[1005];
int dis1[1005];
bool vis[1005];
void spfa(int *dis,vector<node>*G)
{
    int i;
    for(i=1;i<=n;++i)
    {
        dis[i]=inf;
        vis[i]=0;
    }
    int top=0;
    dis[x]=0;
    q[top++]=x;
    while(top)
    {
        int u=q[--top];
        vis[u]=0;
        for(int i=0,l=G[u].size();i<l;++i)
        {
            int v=G[u][i].v;
            int w=G[u][i].w;
            int t=dis[u]+w;
            if(dis[v]>t)
            {
                dis[v]=t;
                if(!vis[v])
                {
                    vis[v]=1;
                    q[top++]=v;
                }
            }
        }
    }
}
void fan()
{
    node t;
    for(int i=1;i<=n;++i)
        for(int j=0,l=G[i].size();j<l;++j)
    {
        int v=G[i][j].v;
        t.v=i;
        t.w=G[i][j].w;
        G1[v].push_back(t);
    }
}
int main()
{
    int i;
    scanf("%d%d%d",&n,&m,&x);
    int u;
    node t;
    while(m--)
    {
        scanf("%d%d%d",&u,&t.v,&t.w);
        G[u].push_back(t);
    }
    spfa(dis,G);
    fan();
    spfa(dis1,G1);
    int MAX=0;
    for(i=1;i<=n;++i)
    {
        MAX=max(MAX,dis[i]+dis1[i]);
    }
    printf("%d\n",MAX);
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值