LightOJ 1422 Halloween Costumes

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci (1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4



 

题意:给你n天分别要穿的衣服编号,可以套着穿,但是一旦脱下来就不能再穿了,(类似栈,只要弹出来了,就不能用了)问这n天最少要准备几件衣服。

刚开始看到这题,完全想不到跟区间dp有什么关系啊。。。。。。我想跟上面一题的共同点就是在区间ij之间会有一个过渡点k,来更新答案。还是先多做几道题,不断总结一下。


我的理解。。。

dp[i][j]为第i天到第j天要穿的最少衣服,考虑第i天,如果后面的[i+1, j]天的衣服没有和第i天相同的,那么dp[i][j] = dp[i + 1][j] + 1。也可以算是一个默认值。

然后在区间[i +1, j]里面找到和第i天衣服一样的日子,尝试直到那天都不把i脱掉,也就是说如果这件衣服不脱掉的话,

那么就会有dp[i][j] = dp[i + 1][k - 1] + dp[k][j],当然我们取所有可能情况的一个最小值就可以。


区间dp基本都是i倒着循环,j正着循环。


感觉区间dp基本上是空白,完全不怎么懂这个套路,不过估计就是固定ijk这种,不过还是先多做题总结一下。

#include <cstdio>
#include <algorithm>
#include <cmath>

using namespace std;
typedef long long LL;
const int inf = 1e9;
const int MAXN = 100+7;
int n,m;
int num[MAXN];
int dp[MAXN][MAXN];

int main()
{
    int t;
    scanf("%d",&t);
    int ca = 0;
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 1 ; i <= n ; ++i)scanf("%d",&num[i]);
        for(int i = n ; i >= 1; --i)
            for(int j = i ; j <= n ;++j)
        {
            dp[i][j] = dp[i+1][j] + 1;
            for(int k = i+1 ; k <= j ; ++k)
            {
                if(num[k] == num[i])dp[i][j] = min(dp[i][j],dp[i+1][k-1] + dp[k][j]);
            }
        }
        printf("Case %d: %d\n",++ca,dp[1][n]);
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值