LightOJ 1070 Algebraic Problem

Given the value of a+b and ab you will have to find the value of an+bna and b not necessarily have to be real numbers.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains three non-negative integers, p, q and n. Here p denotes the value of a+b and qdenotes the value of ab. Each number in the input file fits in a signed 32-bit integer. There will be no such input so that you have to find the value of 00.

Output

For each test case, print the case number and (an+bn) modulo 264.

Sample Input

2

10 16 2

7 12 3

Sample Output

Case 1: 68

Case 2: 91


嗯,一开始说对2^64取模,一脸懵逼,心想这个怎么做啊。然后用的是unsigned long long  超过64会自动取模的。。。。emmmmmm那你如果是个负数也取模成正数么。

估计应该是的,负数应该变成正的,实际上也不能算错吧。

这个咋一看会想到(a+b)^n然后,展开发现仍旧不能做,实际上我们换个想法,能不能找到递推式呢?不难发现a^(n+1) + b^(n+1) = p(a^n+b^n) - q(a^(n-1) + b^(n-1)。

也就是要求的F(n) = p*F(n-1) - q*F(n-2)。

然后就可以矩阵快速幂加速了。

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;
typedef unsigned long long LL;
const LL mod = 7;
const int Size = 2;
long long n,p,q;

struct matrix
{
    LL a[4][4]= {{0}};
    matrix operator *(const matrix b)const
    {
        matrix ans;
        for(int i = 0; i < Size; ++i)
            for(int k = 0; k < Size; ++k)
                for(int j = 0; j < Size; ++j)
                {
                    ans.a[i][j] = (ans.a[i][j] + a[i][k]*b.a[k][j]);
                }
        return ans;
    }
};
LL get_ans()
{
    if(n == 0)return 2;
    matrix ans,base;
    ans.a[0][0] = p;
    ans.a[0][1] = 2;
    base.a[0][0] = p;
    base.a[0][1] = 1;
    base.a[1][0] = -q;
    n--;
    while(n)
    {
        if(n & 1)ans = ans*base;
        base = base*base;
        n >>= 1;
    }
    return ans.a[0][0];
}



int main()
{
    //cout <<INT_MAX<<endl;
    int t;
    int ca = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld%lld%lld",&p,&q,&n);
        printf("Case %d: %llu\n",++ca,get_ans());
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值