1031 Hello World for U (20 分)

 

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworldcan be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

推荐代码:

#include<cstdio>
#include<cstring>
int main(int argc, char const *argv[])
{
    char str[82];
    fgets(str, 83, stdin);
    //gets(str); 不安全
    int N = strlen(str) - 1;//获取长度,减去换行符
    int n1 = (N + 2) / 3, n3 = n1 ,n2 = N + 2 - n1 - n3;//n1,n3为u的两侧,n2为u的底端

    for (int i = 0; i < n1 - 1; ++i)//打印u的两侧
      {
        printf("%c", str[i]);
          for (int j = 0; j < n2 - 2; ++j)
          {
              printf(" ");
          }
        printf("%c\n", str[N - i - 1]);
      }  

    for (int i = 0; i < n2; ++i)//打印u的底端
    {
        printf("%c", str[n1 + i - 1]);
    }
    printf("\n");
    return 0;
}

参考代码:

#include<cstdio>
#include<cstring>
int main(int argc, char const *argv[])
{
    char str[82],ans[30][30];
    fgets(str, 83, stdin);
    int N = strlen(str) - 1;
    int n1 =(N + 2) / 3 , n3 = n1 , n2 = N + 2 - n1 - n3;

    for (int i = 1; i <= n1; ++i)
    {
     for (int j = 1; j <= n2; ++j)
        {
            ans[i][j] = ' ';
        }   
    }

    int pos = 0;
    
    for (int i = 1; i <= n1; ++i)//从上往下,打印u的左侧
    {
        ans[i][1] = str[pos++];
    }

    for (int i = 2; i <= n2; ++i)//从左往右打印u的底端【除去最左侧】
    {
        ans[n1][i] = str[pos++];
    }

    for (int i = n3 -1; i >= 1; --i)//从下往上打印u的右侧【除去最下面】
    {
        ans[i][n2] = str[pos++];
    }

for (int i = 1; i <= n1; ++i)
{
    for (int j = 1; j <= n2; ++j)
    {
        printf("%c", ans[i][j]);
    }
    printf("\n");
}

    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

繁星蓝雨

如果觉得文章不错,可以请喝咖啡

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值