UVA 674 coin change

Description

Download as PDF

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.  

Sample Input 

11
26

Sample Output 

4
13


DP题,有点贪心思想;

枚举一类钱出现的可能性,

则当前状态是上一种钱币的可能性;

且让DP【0】=1;

 f[i, v] = f[i-1, v] + f[i, v-c[i]].  表示前i种钱币的方法v

#include <bits/stdc++.h>
using namespace std ;
int a[5]={1,5,10,25,50};
int dp[500000];
int main()
{
	dp[0]=1;
	for(int i = 0;i<5;i++)
	{
		for(int j =a[i];j<=8000;j++)
		{
			dp[j]+=dp[j-a[i]];
		}
	}
	int n ;
	while(cin>>n)
	{
		cout<<dp[n]<<endl;
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值