HDU 1856 More is better

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input

    
    
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output

    
    
4 2

Hint

 A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers. 
         
 

题意:老师要选人去XXX,然后希望同学们都可以拉自己的关系去,最后需要计算某               个集合中最多的人数,这个理解了半天,现在把题中给的两组数据解释一下;             PS:当不选的时候是1;

样例1:1-2;3-4;5-6;1-6 ;  所以 1 、 2 、 5 、 6 是关系好的同学,

    所以有两个集合, {1,2,5,6}和{3,4};而前者元素多,是四个;

样例2:  1-2;3-4;5-6;7-8;

    {1,2},{3,4},{5,6},{7,8};

   比较后发现都是两个, 所以输出2 ;

题解:首先是并查集的套路, 找到父节点和子节点的关系;合并集合

    结点信息是1,而不是初始化为0;

          额外操作就是将父节点算到子节点里面,合并元素个数;

        然后再遍历子节点所包含的元素个数     就可以了;

   我直接按题中给的最大值暴力搞了,竟然AC了;

优化思路:找到最大结点,则遍历从这里开始;


AC代码;(极限数据) PS 优化代码在下面;

#include <bits/stdc++.h>
using namespace std ;
int vis[10000000+50],pre[10000000+50],ans , m , n ;
int find(int x )
{
	if(x!=pre[x])
	return pre[x]=find(pre[x]);
	return x ;
}
void mix(int x , int y)
{
	int dx = find(x);
	int dy = find(y);
	if(dx!=dy)
	{
		pre[dx]=dy;
		vis[dy]+=vis[dx];
	}
}
int main()
{
	while(cin>>m)
	{
		if(m==0)
		{
			printf("1\n");
			continue ;
		}
		int a, b ,max ;
		for (int i = 1 ; i<=10000000+50;i++)
		{
			 pre[i]=i;
			 vis[i]=1; 
	    }	
	    max = 0 ;
		for(int i =1;i<=m;i++)
		{
			cin>>a>>b;
			mix(a,b);
		}
		for(int i = 1 ; i<=10000000+50;i++)
		{
			if(vis[i]>max)	
				max= vis[i];	
		}
		cout<<max<<endl;
	}
	return 0 ;
}

AC(优化版本)PS:cin会额外降低运行效率,最好都把里面的改成scanf;

#include <bits/stdc++.h>
using namespace std ;
int vis[10000000],pre[10000000],ans , m , n ;
int find(int x )
{
	if(x!=pre[x])
	return pre[x]=find(pre[x]);
	return x ;
}
void mix(int x , int y)
{
	int dx = find(x);
	int dy = find(y);
	if(dx!=dy)
	{
		pre[dx]=dy;
		vis[dy]+=vis[dx];
	}
}
int main()
{
	while(cin>>m)
	{
		if(m==0)
		{
			printf("1\n");
			continue ;
		}
		int a, b ,max ;
		for (int i = 1 ; i<=10000000;i++)
		{
			 pre[i]=i;
			 vis[i]=1; 
	    }	
	    max = 0 ;
		for(int i=1;i<=m;i++)  
        {  
            cin>>a>>b; 
            if(a>max)  
                max=a;  
            if(b>max)  
                max=b;  
            mix(a,b); /*合并集合*/  
        }  
        int ans=0;  
        for(int i=1;i<=max;i++)  
            if(vis[i]>ans) /*查找最大值*/  
                ans=vis[i];  
		cout<<ans<<endl;
	}
	return 0 ;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值