POJ 2377 Bad Cowtractors 【最大生成树】

Description

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

题目大意:坏奶牛:为了破坏农夫约翰的光纤计划,奶牛决定骗丫拉一条最长的网络

题解:可以把图用负值存起来求最小生成树,最后答案变为正值,就是最大生成树

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define inf 0Xfffffff
using namespace std;
int map[1010][1010];
int dis[1010] , vis[1010] , n , m ; 
void prim()
{
    int mini , k , ans = 0 ;
    for(int i = 1 ; i<=n ; i++) dis[i] = map[1][i];
    dis[1]=0;
    vis[1]=true;
    for(int i=2; i<=n; i++)
    {
        mini = inf ;
        for(int j=1; j<=n; j++) if(!vis[j]&&dis[j]<mini) mini = dis[k=j];
        if(mini==inf)
        {
        	printf("-1\n");
        	return ;
		}
        vis[k] = 1 , ans+=mini;
        for(int j=1; j<=n; j++ )if(!vis[j]&&dis[j]>map[k][j]) dis[j] = map[k][j];
    }
    cout<<-ans<<endl;
}
int main()
{
    while(cin>>n>>m)
    {
        for(int i = 1 ; i<=n;i++)
        {
        	for(int j = 1 ; j<=n;j++)
        	{
        		map[i][j] = inf;
			}
			dis[i] = inf ;
			map[i][i] = 0 ;
			vis[i] = 0 ;
		}
        for(int i=1; i<=m; i++)
        {
            int a , b , len ;
            scanf("%d%d%d",&a,&b,&len);
            if(map[a][b]>-len) map[a][b] = map[b][a] = -1*len ;
        }
        prim();
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值