HDU 2669 Romantic [扩展欧几里得]

Description

The Sky is Sprite. 
The Birds is Fly in the Sky. 
The Wind is Wonderful. 
Blew Throw the Trees 
Trees are Shaking, Leaves are Falling. 
Lovers Walk passing, and so are You. 
................................Write in English class by yifenfei 

 

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem! 
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. 

Input

The input contains multiple test cases. 
Each case two nonnegative integer a,b (0<a, b<=2^31) 

Output

output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. 

Sample Input

77 51
10 44
34 79

Sample Output

2 -3
sorry
7 -3

题目大意:给出a b , 让你找出非负x 和 y(y可负数) , 让 a*x + b*y = 1 ; 

题解:记得要判断x 和 y , 

AC代码:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define ll long long

using namespace std ;
long long  gcd (ll a , ll b )
{
    if(a%b==0) return b ;
    else return gcd(b,a%b);
}
void extend_gcd(ll a , ll b , ll &x , ll &y)
{
    if(b==0)
    {
        x = 1 ;
        y = 0 ;
        return ;
    }

    extend_gcd(b,a%b,x,y);
    int r = x;
    x = y ;
    y = r - (a/b)*y;
}
int main()
{
    ll a , b , n , t ;
    while(cin>>a>>b)
    {
        ll x , y ;
        extend_gcd(a,b,x,y);
        if(x*a+y*b == 1)
        {
            while(x<0)
            {
                x+=b;
                y-=a;
            }
            cout<<x<<" "<<y<<endl;
        }
        else cout<<"sorry"<<endl;
    }
    return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值