lightoj 1370 Bi-shoe and Phi-shoe 【欧拉函数应用】

Description

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha


欧拉函数:对正整数N,欧拉函数是小于等于N中所有与N互质的数的个数;例如φ(8)=4,因为1,3,5,7均和8互质

题目大意:F(x)表示对x的欧拉函数; 现在有n个幸运数字k 代表的是f(k)的值,要求出比k大的数的最小值F(m),并求累加和m;

题解:对于素数而言, F(x)= x -1 ; 想让F(x)尽可能的小, 就是让x-1是个素数, 比如 x = 6 ; 6+1 = 7 ; 且是素数, 这样最合理;所以搜索的时候就从x+1开始搜出一个素             数就是最小值了,顺带打个100w的素数表;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;
bool prim[1100000];
void init()
{
    memset(prim,1,sizeof(prim));
    prim[1] = 0;
    for(int i = 2; i <= 1100000; i++)
    {
        if(prim[i])
        {
            for(int j = i*2; j <= 1100000; j += i)
            {
                prim[j] = 0;
            }
        }
    }
}
int main()
{
    int t ,count = 1 ;
    cin>>t;
    init();
    while(t--)
    {
        long long sum = 0 , a ;
        int n ;
        cin>>n;
        for(int i = 0 ; i < n ; i++)
        {
            scanf("%lld",&a);
            for(long long  j = a+1;;j++)
            {
                if(prim[j])
                {
                    sum+=j;
                    break;
                }
            }
        }
        printf("Case %d: ",count++);
        cout<<sum<<" Xukha"<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值