Nim POJ2975

来自《挑战程序设计竞赛》

1.题目原文

Nim
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5605 Accepted: 2635

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n piles having k1k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101
 

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0

Source

2.解题思路

经典Nim游戏,参见博客 http://blog.csdn.net/qq_33929112/article/details/52529928,也可自行谷歌百度。

经典算法中,XOR=k0^k1^…^kn-1,若为0,则先手必败,否则必胜。在必胜态时,先手要做的就是拿走某堆石头中的m个,使得XOR变为0,将必败态转嫁给后手,题目就是在问有几种使XOR变为0的方法。

假设从第i堆石头拿走m块就是这些方法中的一种,则有(ki-m)^(XOR^ki)=0。这里(ki-m)代表第i堆石头拿走m块剩余的部分,(XOR^ki)代表从XOR中去掉ki这一项,因为一个数连续异或两遍任意数都保持不变。

再来看(ki-m)^(XOR^ki)=0,若两个数异或后结果为0,则说明这两个数相等(每一个比特都相等)。于是ki-m=XOR^ki,也即m=ki-XOR^ki。同时m必须满足1≤m≤ki,所以ki>XOR^ki,如此才能为第i堆石头带来一个可行解。

3.AC代码

#include <iostream>
#include<cstdio>
using namespace std;

#define maxn 1005

int n;
int k[maxn];

void solve()
{
    int XOR=0;
    for(int i=0;i<n;i++){
        XOR^=k[i];
    }
    int res=0;
    for(int i=0;i<n;i++){
        if(k[i]>(XOR^k[i])){
            res++;
        }
    }
    cout<<res<<endl;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        for(int i=0;i<n;i++){
            scanf("%d",&k[i]);
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值