poj 2566 Bound Found

Bound Found
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 3197 Accepted: 973 Special Judge

Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0

Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15

Source

Ulm Local 2001


解题思路

因为前缀和不单调,所以需要先排序。在原数组开头添加0,求出前缀数组。题目即转化为在前缀数组中找pre[i],pre[j],两者之差最接近t,。对于每次找到的2个下标分别为i和j的2个数,所对应a的区间为[min(i, j) + 1, max(i, j)]。

那么前缀数组排序后,尺取法便可以求得最接近t的值。


AC代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <utility>
#include <algorithm>
using namespace std;
typedef long long LL;
#define INF 0x7fffffff
typedef pair<int,int> P;
const int maxn =1e5+10;

int n,k;
int t;
int a[maxn];
P pre[maxn];

int main(){
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    while(scanf("%d%d",&n,&k)==2&&n&&k){
        pre[0].first=0;
        pre[0].second=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            pre[i].first=pre[i-1].first+a[i];
            pre[i].second=i;
        }
        sort(pre,pre+n+1);

        for(int i=0;i<k;i++){
            scanf("%d",&t);
            int ansl,ansr;
            int ans,diff=INF;
            int l=0,r=1;
            while(r<=n){
                int sub=pre[r].first-pre[l].first;
                if(abs(sub-t)<diff){
                    diff=abs(sub-t);
                    ansl=min(pre[r].second,pre[l].second)+1;
                    ansr=max(pre[l].second,pre[r].second);
                    ans=sub;
                }

                if(sub<t) r++;
                else if(sub>t) l++;
                else break;

                if(l==r) r++;
            }

            printf("%d %d %d\n",ans,ansl,ansr);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值