BFS(2)-非常可乐

题目:

Problem Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出"NO"。
 

Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以"0 0 0"结束。
 

Output
如果能平分的话请输出最少要倒的次数,否则输出"NO"。
 

Sample Input
  
  
7 4 3<br>4 1 3<br>0 0 0
 

Sample Output
No
3
思路:其实这题思路也不难,和上一题一样
#include<stdio.h>
#include<stdlib.h>
#include<queue>
using namespace std;
struct N{
	int a,b,c;
	int t;
};

queue <N> Q;
bool mark[100][100][100];

void atoi(int &a,int sa,int &b,int sb)
{
	if(sb-b>=a)
	{
		b+=a;
		a=0;
	}else{
		a-=sb-b;
		b=sb;
	}
}
int BFS(int s,int n,int m)
{
	while(Q.empty()==false){
		N now=Q.front();
		Q.pop();
		int a,b,c;
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(a,s,b,n);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
		  Q.push(tmp);
		}
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(b,n,a,s);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
		  Q.push(tmp);
		}
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(a,s,c,m);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
		  Q.push(tmp);
		}
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(c,m,a,s);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
	      Q.push(tmp);
		}
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(b,n,c,m);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
		  Q.push(tmp);
		}
		a=now.a;
		b=now.b;
		c=now.c;
		atoi(c,m,b,n);
		if(mark[a][b][c]==false){
		  mark[a][b][c]=true;
		  N tmp;
		  tmp.a=a;
		  tmp.b=b;
		  tmp.c=c;
		  tmp.t=now.t+1;
		  if(a==s/2&&b==s/2) return tmp.t;
		  if(b==s/2&&c==s/2) return tmp.t;
		  if(a==s/2&&c==s/2) return tmp.t;
		  Q.push(tmp);
		}
	}
	return -1;
}

int main()
{
	int s,n,m;
	while(scanf("%d%d%d",&s,&n,&m)!=EOF){
		if(s==0) break;
		if(s%2==-1){ 
			printf("No\n");
			continue;
		}
		for(int i=0;i<=s;i++){
			for(int j=0;j<=n;j++){
				for(int k=0;k<=n;k++)
				{
					mark[i][j][k]=false;
				}
			}
		}
		N tmp;
		tmp.a=s;
		tmp.b=tmp.c=tmp.t=0;
		while(Q.empty()==false)Q.pop();
		Q.push(tmp);
		mark[s][0][0]=true;
		int ret=BFS(s,n,m);
		if(ret==-1)
			printf("No\n");
		else printf("%d\n",ret);
	}
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值