1105. Spiral Matrix (25)

1105. Spiral Matrix (25)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define mx 10010
int ans[mx];
int dp[mx][mx];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int N;
	int n,m;
	scanf("%d",&N);
	memset(ans,0,sizeof(ans));
	for(int i=0;i<N;i++)
	{
		scanf("%d",&ans[i]);
	}
	if(N==1){ //不能忽略,否则某个case通过不了
		printf("%d",ans[0]);
		return 0;
	}
	sort(ans,ans+N,cmp);

	//int idx,minnum=99999,num,x,y;
	/*for(int j=2;j<=N;j++) //按这个方法求比较麻烦,但是也可行
	{
		if(N%j!=0)continue;
		idx=N/j;
		if(idx>j){
			x=idx;
			y=j;
		}else{
			x=j;
			y=idx;
		}
		num=x-y;
		if(num<minnum)
		{
			minnum=num;
			m=x;n=y;
		}
	}*/
	//printf("%d %d",n,m);
	m=(int)ceil(sqrt(1.0*N));
	while(N%m!=0)
	{
		m++;
	}
	n=N/m;
	int D=n,B=m,L=1,U=1,now=0;
	int i=1,j=1;
	while(now<N)
	{
		while(now<N&&j<D)
		{
			dp[i][j]=ans[now++];
			j++;
		}
		while(now<N&&i<B)
		{
			dp[i][j]=ans[now++];
			i++;
		}
		while(now<N&&j>L)
		{
			dp[i][j]=ans[now++];
			j--;
		}
		while(now<N&&i>U)
		{
			dp[i][j]=ans[now++];
			i--;
		}
		U++,L++,D--,B--;
		i++,j++;
		if(now==N-1){//最后一个数据单独处理,否则某个case通过不了
			dp[i][j]=ans[now++];
		}
	}
	for(int i=1;i<=m;i++){
		for(int j=1;j<=n;j++){
			if(j!=1)printf(" ");
			printf("%d",dp[i][j]);
		}
		printf("\n");
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值