【PAT甲级】1001 A+B Format

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

个人思路

水题略过

代码实现

#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define ep 1e-2
using namespace std;

const int maxn = 15;

int main() {
    int a, b;
    cin >> a >> b;
    
    int sum = abs(a + b), cnt = 0;
    string sum_str = "";
    if (a + b == 0) {
        sum_str += '0';
    }
    else {
        while (sum != 0) {
            cnt ++;
            sum_str = char((sum%10)+'0') + sum_str;
            sum /= 10;
            if (cnt % 3 == 0 && sum != 0)
                sum_str = ',' + sum_str;
        }
        if (a + b < 0)
            sum_str = '-' + sum_str;
    }
    cout << sum_str << endl;
    
    return 0;
}

总结

学习不息,继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值