(优先队列)poj2431Expedition

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

Source

USACO 2005 U S Open Gold


//燃料不足,才加油,加前面通过的最大值
//优先队列

//当燃料箱不为空

//将c[i]加入到队列中
//当燃料箱空了的时候
//如果优先队列为空,则无法到达终点
//否则取出优先队列中的最大元素用来给卡车加油


#include <iostream>
#include <cstdio>
#include <queue>
#include <cmath>
#include <algorithm>
#define maxn 10010
int d[maxn], c[maxn];
int ans, pos, tank, n;
using namespace std;

//燃料不足,才加油,加前面通过的最大值
//优先队列

//当燃料箱不为空
//将c[i]加入到队列中
//当燃料箱空了的时候
//如果优先队列为空,则无法到达终点
//否则取出优先队列中的最大元素用来给卡车加油

void solve()
{
    priority_queue<int> pque;
    for(int i = 0; i <= n; i++)
    {
        int dis = d[i] - pos;
        //油量不够到达d[i]
        while(tank - dis < 0)
        {
            //队列为空,没有加油站可以加油
            while(pque.empty())
            {
                printf("%d\n", -1);
                return;
            }
            //不为空取出最大值,加到油箱里
            tank += pque.top();
            //取出的元素要删除
            pque.pop();
            ans += 1;
        }
        tank -= dis;
        //当前位置变成了d[i];
        pos = d[i];
        //c[i]加入队列中
        pque.push(c[i]);
    }
    printf("%d\n", ans);
}

int main()
{
    while(~scanf("%d", &n))
    {
        //输入的d是距离终点的距离
        //要转换成距离起点的距离
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &d[i], &c[i]);
        }
        //l是距离,o是油量
        int l, o;
        scanf("%d%d", &l, &o);
        for(int i = 0; i < n; i++)
        {
            d[i] = l - d[i];
        }
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n - i - 1;j++)
            {
                if(d[j] > d[j + 1])
                {
                    int t = d[j];
                    d[j] = d[j + 1];
                    d[j + 1] = t;
                    t = c[j];
                    c[j] = c[j + 1];
                    c[j + 1] = t;
                }
            }
        }
        ans = 0;//加油次数
        pos = 0;//当前位置
        tank = o;//剩余油量,油箱
        //将重点也看作加油站
        d[n] = l;
        c[n] = 0;
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值