poj 2442 Sequence

Sequence
Time Limit: 6000MS Memory Limit: 65536K
Total Submissions: 8969 Accepted: 2992

Description

Given m sequences, each contains n non-negative integer. Now we may select one number from each sequence to form a sequence with m integers. It's clear that we may get n ^ m this kind of sequences. Then we can calculate the sum of numbers in each sequence, and get n ^ m values. What we need is the smallest n sums. Could you help us?

Input

The first line is an integer T, which shows the number of test cases, and then T test cases follow. The first line of each case contains two integers m, n (0 < m <= 100, 0 < n <= 2000). The following m lines indicate the m sequence respectively. No integer in the sequence is greater than 10000.

Output

For each test case, print a line with the smallest n sums in increasing order, which is separated by a space.

Sample Input

1
2 3
1 2 3
2 2 3

Sample Output

3 3 4

Source

POJ Monthly,Guang Lin

/*
给你m个序列,每次从每个序列里挑选一个数让他们相加组成一个数,然后重复这样从而组成一个新的序列,然后输出前n小的序列。
*/
我们可以一步一步的来,先输入两个序列让他们相加,取前n个,一步一步就可以了,,
#include <string.h>
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <iostream>
using namespace std;

int n, m;
int a[20005];
int b[20005];
struct cmp1
{
    bool operator()( int &a, int &b )
    {
        return a<b;
    }
};
priority_queue<int, vector<int>, cmp1> p;

void Pri ()
{
    int i, j;
    while ( !p.empty() )
    {
        p.pop();
    }
    for ( i = 0;i < m; i++ )
    {
        p.push(a[i]+b[0]);
    }
    for ( i = 0;i < m; i++ )
    {
        for ( j = 1;j < m; j++ )
        {
            if( a[i]+b[j] >= p.top() )
            {
                break;
            }
            else
            {
                p.pop();
                p.push( a[i]+b[j] );
            }
        }
    }
    for ( i = m-1;i >= 0; i-- )
    {
        a[i] = p.top();
        p.pop();
    }
}

int main()
{
    int t;
    int i, j;
    scanf ( "%d", &t );
    while ( t-- )
    {
        scanf ( "%d %d", &n, &m );

        for ( i = 0; i < m; i++ )
        {
            scanf ( "%d", &a[i] );
        }
        sort(a,a+m);

        for ( i = 1;i < n; i++ )
        {
            for ( j = 0;j < m; j++ )
            {
                scanf ( "%d", &b[j] );
            }
            sort(b,b+m);
            Pri();
        }

        for ( i = 0;i < m; i++ )
        {
            printf ( i != m-1?"%d ":"%d\n", a[i] );
        }
    }
}

代码菜鸟,如有错误,请多包涵!!!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值