hdoj1211 RSA

题目:
                        RSA

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1949 Accepted Submission(s): 1418

Problem Description
RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

choose two large prime integer p, q
calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

You can encrypt data with this method :

C = E(m) = me mod n

When you want to decrypt data, use this method :

M = D(c) = cd mod n

Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

Now given p, q, e and some cryptograph, your task is to “translate” the cryptograph into plain text.

Input
Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.

Output
For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.

Sample Input
101 103 7 11
7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239

Sample Output
I-LOVE-ACM.

此题就是根据题意将密码转换为对应的信息。
一开始我题意都没读懂,后来在其他资料和大神们的博客中才知道这是信息学里面的RSA密钥算法。

此题关键是要读懂题意,否则真的无从下手。

首先有2个素数,然后n为它们的积,f(n) = (p-1) * (q-1).
然后d为e在mod f(n) 下的逆元,再用快速幂求出c的d次方,再对值求余(mod n)(c为输入的密码)。
此题求逆元可以用扩展欧几里得算法。

参考代码:
#include <iostream>
#include <cstring>
using namespace std;
typedef long long ll;
ll a[1000000];
void input(ll l) {
    for (ll i = 0;i < l;++i) {
        cin >> a[i];
    }
}
ll caln(ll p,ll q) {
    ll n;
    n = p * q;
    return n;
}
ll calf(ll p,ll q) {
    ll f;
    f = (p-1) * (q-1);
    return f;
}
ll exgcd(ll a,ll b,ll &x,ll &y) {
    if (b == 0) {
        x = 1;
        y = 0;
        return a;
    }
    ll r = exgcd(b,a%b,x,y);
    ll t;
    t = x;
    x = y;
    y = t - (a / b) * y;
    return r;   
}
ll quickmod(ll a,ll b,ll mod) {
    ll res = 1;
    a = a % mod;
    while (b > 0) {
        if (b & 1) {
            res = res * a % mod;
        }
        b >>= 1;
        a = a * a % mod;
    }
    return res;
}
int main() {
    ll p,q,e,l;
    while (cin >> p >> q >> e >> l) {
        memset(a,0,sizeof(a));      
        input(l);
        ll n = caln(p,q);
        ll f = calf(p,q);
        ll d;
        ll y;
        ll g = exgcd(e,f,d,y);
        //cout << g << endl;
        if (d < 0) d = d + f;
        //cout << d << endl;
        for (int i = 0;i < l;++i) {
            long long res = quickmod(a[i],d,n) % n;
            cout << char(res);
            //cout << res;
        }
        cout << endl;
    } 
    return 0;
}

一开始我扩展欧几里得弄错了,打出一群笑脸。。。
有什么问题,欢迎交流。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值