HDU 1856 More is better

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 24713    Accepted Submission(s): 8862


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2  

题目大意:找出一群人中直接或间接认识的人 输出最多能找到几个

关于人数的计算 有两种方法
第一种  在join函数里合并时 把人数合并
void join(int a,int b)
{
	int p=find(a);
	int q=find(b);
	if(p!=q)
	{
		pre[p]=q;
		num[q]+=num[p];
	}
}
第二种 整组数据处理完后 在main函数里强搜 
		int Max = 0, sum = 0;
		for (int i = 1; i <= maxn; i++)
		{
			sum = 0;
			if (pre[i] == i)  //找到根节点
				for (int j = 1; j <= maxn; j++)  //强搜所有以i为根节点的数
				{
					if (find(j) == i)
					{
						sum++;
					}
				}
				Max = max(Max, sum);
		}

做法一:
#include <stdio.h>
int pre[100005],num[100005];
void init()
{
	int i;
	for(i=1;i<=100005;i++)
	{
		pre[i]=i;
		num[i]=1;
	}
}
int find(int x)
{ 
	if(pre[x]!=x)
	pre[x]=find(pre[x]);
	return pre[x];
}
void join(int a,int b)
{
	int p=find(a);
	int q=find(b);
	if(p!=q)
	{
		pre[p]=q;
		num[q]+=num[p];
	}
}
int main()
{
	int n,a,b,m,max,i;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		{
			printf("1\n");
			continue;
		}
		m=0;
		init();
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&a,&b);
			if(m<a)
			m=a;
			if(m<b)
			m=b;
			join(a,b);
		}
		
		max=0;
		for(i=1;i<=m;i++)
		{
			if(max<num[i])
			max=num[i];
		}
		printf("%d\n",max);
	}
}

做法二:
#include <cstdio>
#include <cstring>
#include<algorithm>
using namespace std;
int pre[100005];
int find(int x)
{
    if (pre[x] == x)
        return x;
    else
        return pre[x]=find(pre[x]);
}
void join(int x, int y)
{
    int fx = find(x);
    int fy = find(y);
    if (fx != fy)
        pre[fx] = fy;
}

int main()
{
    int t;
    while (~scanf("%d",&t))
    {
        if (t == 0)
        {
            printf("1\n");
            continue;
        }
        int maxn = 0, a, b;
        for (int i = 0; i < 100005; i++)
        {
            pre[i] = i;
        }
        for (int i = 0; i < t; i++)
        {
            scanf("%d%d", &a, &b);
            join(a, b);
            if (maxn < max(a, b))
            {
                maxn = max(a, b);
            }
        }
        int Max = 0, sum = 0;
        for (int i = 1; i <= maxn; i++)
        {
            sum = 0;
            if (pre[i] == i)
                for (int j = 1; j <= maxn; j++)
                {
                    if (find(j) == i)
                    {
                        sum++;
                    }
                }
                Max = max(Max, sum);
        }
        printf("%d\n", Max);
    }
    return 0;
}

说一下极坑的一点  第二种做法 find函数 开始时这样写:
int find(int x)
{
    if (pre[x] == x)
        return x;
    else
        return find(pre[x]);
}
蜜汁超时  炒鸡尴尬
然后改成这样:
int find(int x)
{
    if (pre[x] == x)
        return x;
    else
        return pre[x]=find(pre[x]);
}
就好了。。。。。
不知道为啥 可能是没用rank的缘故吧
总之,很尴尬。。。。




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值