NYOJ221tree(重建二叉树)

描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB

题意:

给你了二叉树的先序遍历和中序遍历,让你写出这个二叉树的后序遍历。

分析:

先序遍历:先访问根节点,然后以前序访问左子树,右子树。
中序遍历:左子树,当前节点,右子树。
根据先序和中序遍历的特点,可以发现如下规律:
先序遍历的每个节点,都是当前子树的根节点。同时,以对应的节点为边界,就会把中序遍历的结果分为左子树和右子树。例如:
先序:a b d c e f 
'a'是根节点
中序:d b a e c f
'a'是根节点,把字符串分成左右两个子树
'a'是先序遍历节点的第一个元素,可以看出,它把中序遍历的结果分成'db'和'ecf'两部分。这就是'a'的左子树和右子树的遍历结果。
如果能够找到先序遍历中对应的左子树和右子树,就可以把'a'作为当前的根节点,然后依次递归下去,这样就能够依次恢复左子树和右子树的遍历结果。 

后序遍历二叉树的操作定义为:
若二叉树为空,则空操作;否则
(1)后序遍历左子树;
(2)后序遍历右子树;
(3)访问根结点。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int MAXN = 30;
char pre[MAXN],in[MAXN];
struct Node {
	char date;
	Node *left,*right;
	Node(char c)
	{
		date = c;
		left = right = NULL;
	}
}; 
void rebulid(Node* &root,char *pre,char *in,int len)//根;父亲结点;子树结点起点;子树结点总数 
{
	if(len<1)
		return ;
	char rc = pre[0];//取第一个父亲结点的值 
	root = new Node(rc);
	int pos;
	for(int i=0;i<len;i++)//从子树结点的起点开始遍历 
	{
		if(in[i]==rc){
			pos = i;break;
		}
	}
	int leftsublen = pos;//左子树的长度 
	int rightsublen = len-pos-1;//右子树的长度
	rebulid(root->left,pre+1,in,leftsublen);//递归左子树 
	rebulid(root->right,pre+leftsublen+1,in+pos+1,rightsublen);//递归右子树 
}
void postTraverse(Node *root) { 
	if (root){ 
	postTraverse(root->left); 
	postTraverse(root->right); 
	cout<<root->date; 
	}
}
int main()
{
	Node *root;
	while(cin>>pre>>in)
	{
		rebulid(root,pre,in,strlen(pre));
		postTraverse(root);
		cout<<endl;
	}
	return 0; 
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值