1053 Path of Equal Weight

Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

        题目的大意是给定一棵树以及一个权重之和W,要求找到所有从根节点开始到达叶子节点,并且路径上的权重之和为W的路径。最后输出所有满足要求的路径上的权值。

       解题思路:使用树的深度遍历方法,当深度遍历至叶子节点时,判断当前从根节点开始累计的权重之和是不是等于目标值,如果相等,将当前路径保存到结果中,如果不是,则返回上一层递归操作;如果当前不是叶子节点,则递归处理所有的子节点(该步骤可以先判断一下当前累计的权重之和是不是已经超过目标值了,这样可以减少不必要的操作)。

      在最终结果输出的时候需要注意,i从0~min(len(a),len(b)), 如果出现a[i] != b[i] 的情况,则若a[i] > b[i],在输出时先输出a。如果最终i=min(len(a),len(b))时仍相等,则若len(a) > len(b) 则在结果输出的时候先输出a。在使用c++的sort 实现的时候,如果cmpare函数中的比较方法不对会出现"invalid comparator"的错误。比如我第一次写的comparator函数为:

bool cmp(const vector<int> &l,sonst vector<int> &r){
	int len = min(l.size(),r.size());
	for(int i=0;i<len;++i){
		if(l[i] > r[i])
			return true;
	}
	return false;
}

如果按照上面的这个比较函数执行的话,例如当l={1,2,3,4},r={1,2,3}时返回的是false; 而当l={1,2,3},r={1,2,3,4}时也会返回false,因此无法正确的确定相对顺序。

正确的写法是这样的:

bool cmp(const vector<int> &l, const vector<int> &r) {
	int len = min(l.size(), r.size());
	for (int i = 0; i < len; ++i) {
		if (l[i] != r[i])
			return l[i] > r[i];
	}
	return l.size() > r.size();
}

实现代码:

#include <iostream>
#include <cstdio>
#include <vector>
#include <unordered_map>
#include <algorithm>
#include <stack>
#define MAX_LEAF	101

using namespace std;

int target_number;
vector<int> path; //the weights on the path by node
vector<vector<int>> result;
int leaf_weights[MAX_LEAF];
bool visited[MAX_LEAF] = {false};

void dfs(unordered_map<int, vector<int>> &node_childs, int curr_id,int weight_sum) {
	if (visited[curr_id])
		return;
	weight_sum += leaf_weights[curr_id];
	path.push_back(leaf_weights[curr_id]);
	visited[curr_id] = true;
	if (node_childs[curr_id].empty()) {
		//curr node is leaf and sum equals target
		if (weight_sum == target_number) {
			result.push_back(path);
			path.pop_back();
			return;
		}
		else {
			path.pop_back();
			return;
		}
	}
	else {
		//curr node is not leaf node
		for (int i = 0; i < node_childs[curr_id].size(); ++i) {
			if (!visited[node_childs[curr_id][i]]) {
				dfs(node_childs, node_childs[curr_id][i], weight_sum);
			}
		}
		path.pop_back();
	}
}

bool cmp(const vector<int> &l, const vector<int> &r) {
	int len = min(l.size(), r.size());
	for (int i = 0; i < len; ++i) {
		if (l[i] != r[i])
			return l[i] > r[i];
	}
	return l.size() > r.size();
}

int main()
{
	int node_count, no_leaf_count, number;
	unordered_map<int, vector<int>> node_childs;
	cin >> node_count >> no_leaf_count >> number;
	target_number = number;
	for (int i = 0; i < node_count; ++i)
		cin >> leaf_weights[i];
	int child_count, id, child_id;
	for (int i = 0; i < no_leaf_count; ++i) {
		cin >> id >> child_count;
		for (int j = 0; j < child_count; ++j) {
			cin >> child_id;
			node_childs[id].push_back(child_id);
		}
	}
	dfs(node_childs, 0, 0);
	//sort the result by descend
	sort(result.begin(), result.end(), cmp);
	for (int i = 0; i < result.size(); ++i) {
		for (int j = 0; j < result[i].size() - 1; ++j)
			cout << result[i][j] << " ";
		cout << result[i][result[i].size() - 1] << endl;
	}

    return 0;
}

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值