【PAT甲级A1044】Shopping in Mars (25分)(c++)

该博客讨论了一个关于在火星上购物的问题,其中支付方式是通过钻石链。问题涉及找到能够凑成特定金额(M火星元)的钻石子序列。如果无法精确匹配金额,需要找到损失最小的解决方案。博主提出了一种算法思路,使用双指针遍历数组并维护一个大于M的最小和的记录,从而找出所有可能的支付选项。文章提供了样例输入和输出,以及相应的C++代码实现。
摘要由CSDN通过智能技术生成

1044 Shopping in Mars (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  • Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  • Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  • Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
    Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10​5​​ ), the total number of diamonds on the chain, and M (≤10​8​​ ), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​ ⋯D​N​​ (D​i​​ ≤10​3​​ for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意:

给出一组数,将其划分可得子数组,要求输出所有子数组和为m的子数组,若找不到,输出和大于m的最小子数组。

思路:

使用两根指正遍历数组,用vector来统计最小大于m的值起始指针全在第一个位置
当指针内数组和小于m时,右指针右移;
若指针内数组和等于m时,输出左右指针位置;
当指针内数组和大于m时且和小于当前最小大于m的值,vector清空,加入当前左右指针,左指针右移;
当指针内数组和大于m是且和等于当前最小大于m的值,vector加入当前左右指针,左指针右移;

参考代码:

#include <cstdio>
#include <vector>
using namespace std;
int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    int arr[n+1];
    for(int i=1;i<=n;i++)
        scanf("%d",&arr[i]);
    vector<pair<int,int>> v;
    bool flag= false;
    int begin=1,end=1,minM=1e9,sum=0;
    while(1){
        if(sum<m){
            if(end>n)break;
            sum+=arr[end++];
        }
        else{
            if(sum==m){
                printf("%d-%d\n",begin,end-1);
                flag=true;
            }else if(sum<minM){
                minM=sum;
                v.clear();
                v.push_back(make_pair(begin,end-1));
            }else if(sum==minM)
                v.push_back(make_pair(begin,end-1));
            sum-=arr[begin++];
        }
    }
    if(!flag){
        for(int i=0;i<v.size();i++)
            printf("%d-%d\n",v[i].first,v[i].second);
    }
    return 0;
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值