【PAT甲级A1119】 Pre- and Post-order Traversals (30分)(c++)

1119 Pre- and Post-order Traversals (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:
For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

题意:

将前序遍历和后序遍历的二叉树用中序遍历输出,若果中序遍历唯一则输出yes,否则no,输出任意一种中序遍历。

思路:

首先所给前序遍历的首值和后序遍历的尾值肯定相等都是根结点
接着,前序的第二个值肯定是左节点,在后序中去找这个值的位置,这个值在后序遍历左边所有的值就是首节点的左子树(包括这个值),右边所有的值就是首节点的右子树。如图:
在这里插入图片描述
以此递归将左右子树加以区分,当某一个值的左右子树都为空时,这个点既可以作为当前前序首值的左子树,也可作为右子树,所以这种情况下中序遍历不唯一。(注意:当输出中序遍历后要换行,很坑,不然所有格式错误)

参考代码:

#include <iostream>
#include <algorithm>
#include <vector>

using namespace std;
struct Node{
    int val;
    Node *left,*right;
    Node(int data):val(data),left(NULL),right(NULL){}
};
vector<int> pre(31),pos(31);
int n,flag=1,cnt=0;
Node * creat(int prel,int prer,int posl,int posr){
    if(prel>prer||posl>posr)return NULL;
    Node *root=new Node(pre[prel]);
    if(prer==prel)return root;
    int k;
    for(k=posl;k<=posr;k++)
        if(pos[k]==pre[prel+1])break;
    int numleft=k-posl;
    if(numleft==0&&posr==k+1)flag=0;
    root->left=creat(prel+1,prel+numleft+1,posl,k);
    root->right=creat(prel+numleft+2,prer,k+1,posr-1);
    return root;
}
void showinorder(Node *root){
    if(root==NULL) return;
    showinorder(root->left);
    if(cnt!=0)printf(" ");
    cnt++;
    printf("%d",root->val);
    showinorder(root->right);
}

int main() {
    scanf("%d",&n);
    for(int i=1;i<=n;i++)scanf("%d",&pre[i]);
    for(int i=1;i<=n;i++)scanf("%d",&pos[i]);
    Node *root=creat(1,n,1,n);
    if(flag)printf("Yes\n");
    else printf("No\n");
    showinorder(root);
    printf("\n");
    return 0;
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值