HDOJ 1098 ”Ignatius's puzzle“

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1098

Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

 

Input

The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

 

Output

The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

 

Sample Input

11 100 9999

 

Sample Output

22 no 43

注:65|f(x)是f(x)能被65整除。

此题属于数论里面的费马小定理:

数论中的一个重要定理,其内容为:

假如p是质数,且gcd(a,p)=1,那么 a(p-1)≡1(mod p)。即:假如a是整数,p是质数,且a,p互质(即两者只有一个公约数1),那么a的(p-1)次方除以p的余数恒等于1。

a^(p-1)%p=1

(其中%为取模操作,且a<p,p为质数)

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
    int k;
    while(~scanf("%d", &k))
    {
        int i;
        for(i=1;i<=65;i++){
             if((18+k*i)%65==0)
             {
                 printf("%d\n",i);
                 break;
             }
            
        }
       if(i>65)
           printf("no\n");
           
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

那就可爱多一点点

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值