Fibonacci 快速幂矩阵

Fibonacci
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 16050
Accepted: 11288

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


这题看 题上写的就是矩阵的幂,这个可以套用快速幂的模版把a=a*a改成A=A*A;再写个矩阵相乘的函数即可;
其实就大的Fibonacci 数用的就是快速幂

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;


struct M
{
int a[5][5];
void init()
{
a[1][1]=a[1][2]=a[2][1]=1;
a[2][2]=0;
}
}A;


M chengfa(M b,M c)
{
M ans;
for(int i=1;i<=2;i++)
{
for(int j=1;j<=2;j++)
{
ans.a[i][j]=0;
for(int k=1;k<=2;k++)
{
ans.a[i][j]+=b.a[i][k]*c.a[k][j];
}
ans.a[i][j]=ans.a[i][j]%10000;
}
}
return ans;
}


M pow(M a,int b)
{
M ans;
ans.a[1][1]=1;
ans.a[2][2]=1;
ans.a[1][2]=0;
ans.a[2][1]=0;
while(b)
{
   if(b&1)
ans=chengfa(ans,a);
b>>=1;
a=chengfa(a,a);
}
return ans;
}
int main()
{
int n;
while(cin>>n,n!=-1)
{
M a;
a.init();
M b=pow(a,n);
cout<<b.a[1][2]<<endl;
}
return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值