PAT-Shortest Distance

题目描述
The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.
输入
Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.
输出
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
样例输入 Copy
5 1 2 4 14 9
3
1 3
2 5
4 1
样例输出 Copy
3
10
7
代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn = 100005;
int sum[maxn];
//暴力解法超时
// int dis[maxn];
// int main()
// {
//     int n;
//     scanf("%d",&n);
//     int sum = 0;
//     for (int i = 1; i <= n; i++)
//     {
//         scanf("%d",&dis[i]);
//         sum += dis[i];
//     }
//     int t;
//     scanf("%d",&t);
//     while (t--)
//     {
//         int num1, num2, sum1 = 0;
//         scanf("%d %d",&num1,&num2);
//         if (num1 > num2){
//             swap(num1,num2);
//         }
//         for(int i=num1;i<num2;i++){
//             sum1+=dis[i];
//         }
        
//         printf("%d\n", sum1 < sum - sum1 ? sum1 : sum - sum1);
//     }
//     return 0;
// }
int main(){
    int n;
    scanf("%d",&n);
    sum[0]=0;
    for(int i=1;i<=n;i++){
        int temp;
        scanf("%d",&temp);
        sum[i]=temp;
        sum[i]+=sum[i-1];//求和数组
    }
    int t;
    scanf("%d",&t);
    while(t--){
        int num1, num2;
        scanf("%d %d",&num1,&num2);
        if(num1>num2){
            swap(num1,num2);
        }
        int x=sum[num2-1]-sum[num1-1];
        printf("%d\n",x<sum[n]-x?x:sum[n]-x);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值