对称矩阵的判定
Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
输入矩阵的行数,再依次输入矩阵的每行元素,判断该矩阵是否为对称矩阵,若矩阵对称输出“yes”,不对称输出”no“。
Input
输入有多组,每一组第一行输入一个正整数N(N<=20),表示矩阵的行数(若N=0,表示输入结束)。
下面依次输入N行数据。
Output
若矩阵对称输出“yes”,不对称输出”no”。
Example Input
3
6 3 12
3 18 8
12 8 7
3
6 9 12
3 5 8
12 6 3
0
Example Output
yes
no
Hint
Author
#include <stdio.h>
#include <stdlib.h>
int main()
{
int a[50][50],i,j,n;
while(~scanf("%d",&n)&&n!=0)
{
int flag = 0;//标记变量
for(i = 0;i < n;i++)
{
for(j = 0;j < n;j++)
{
scanf("%d",&a[i][j]);
}
}
for(i = 0;i < n;i++)
{
for(j = 0;j < n;j++)
{
if(a[i][j]!=a[j][i])
{
flag = 1;
break;
}
}
}
if(flag)printf("no\n");
else printf("yes\n");
}
return 0;
}