https://www.luogu.org/problemnew/show/P3956
题目描述
有一个m×mm \times mm×m的棋盘,棋盘上每一个格子可能是红色、黄色或没有任何颜色的。你现在要从棋盘的最左上角走到棋盘的最右下角。
任何一个时刻,你所站在的位置必须是有颜色的(不能是无色的), 你只能向上、 下、左、 右四个方向前进。当你从一个格子走向另一个格子时,如果两个格子的颜色相同,那你不需要花费金币;如果不同,则你需要花费 11 1个金币。
另外, 你可以花费 222 个金币施展魔法让下一个无色格子暂时变为你指定的颜色。但这个魔法不能连续使用, 而且这个魔法的持续时间很短,也就是说,如果你使用了这个魔法,走到了这个暂时有颜色的格子上,你就不能继续使用魔法; 只有当你离开这个位置,走到一个本来就有颜色的格子上的时候,你才能继续使用这个魔法,而当你离开了这个位置(施展魔法使得变为有颜色的格子)时,这个格子恢复为无色。
现在你要从棋盘的最左上角,走到棋盘的最右下角,求花费的最少金币是多少?
输入输出格式
输入格式:
第一行包含两个正整数m,n m, nm,n,以一个空格分开,分别代表棋盘的大小,棋盘上有颜色的格子的数量。
接下来的n n n行,每行三个正整数x,y,c x, y, cx,y,c, 分别表示坐标为(x,y)(x,y)(x,y)的格子有颜色c cc。
其中c=1 c=1c=1 代表黄色,c=0 c=0c=0 代表红色。 相邻两个数之间用一个空格隔开。 棋盘左上角的坐标为(1,1)(1, 1)(1,1),右下角的坐标为(m,m)( m, m)(m,m)。
棋盘上其余的格子都是无色。保证棋盘的左上角,也就是(1,1)(1, 1)(1,1) 一定是有颜色的。
输出格式:
一个整数,表示花费的金币的最小值,如果无法到达,输出−1-1−1。
输入输出样例
输入样例#1: 复制
5 7 1 1 0 1 2 0 2 2 1 3 3 1 3 4 0 4 4 1 5 5 0
输出样例#1: 复制
8
输入样例#2: 复制
5 5 1 1 0 1 2 0 2 2 1 3 3 1 5 5 0
思路:为何用优先队列呢?因为这里父节点的下一步所有的子节点花费的金币不一样
而要求最少的耗费的金币,所以这里我们需要把当前队列中金币花费最少的出队
然后找它的下一步所有的子节点,并且加入队列中,然后重复以上步骤
错误思路:把父节点的下一步所有的子节点,并且加入队列中,然后把队首元素出队,
注意这里可能会把金币花费最少的路径给破坏了(同一个子节点可由一个或多个
父节点扩展得到,这里使用标记后会让最优解里的某些子节点变成其它路径的节点)
AC:
#include <iostream>
#include<queue>
using namespace std;
int map[105][105];
struct Que
{
int x,y;
int money;
int color;
bool change = false;
friend bool operator < (Que a,Que b){//反正用了优先队列就要用这个来表示排序规律(也就是优先顺序)
return a.money > b.money;//以金币小号谁小谁在前面,注意如果是想要达到a<b那么就要写b>a
}
};
int m,n,next[4][2]={0,1,1,0,0,-1,-1,0};
int book[105][105]={0};
void init()
{
for(int i = 1;i <= m;++i)
for(int j = 1;j <= m;++j)
map[i][j] = -1;
}
int main() {
priority_queue <Que> que;
Que first;
cin>>m>>n;
init();
for(int i=0;i<n;i++){
int x,y,c;
cin>>x>>y>>c;
map[x][y]=c;
}
int ans = -1;
first.x=1;first.y=1;first.change=false;first.money = 0;
que.push(first);
book[1][1] = 1;
while(!que.empty())
{
Que t = que.top();
que.pop();
if(t.x == m && t.y == m)
{
ans = t.money;
break;
}
for(int k = 0;k < 4;++k)
{
int tx = t.x+next[k][0];
int ty = t.y+next[k][1];
if(tx < 1 || ty < 1 || tx > m || ty > m) continue;
if(t.change && map[tx][ty] == -1) continue;
if(map[tx][ty] != -1 && !book[tx][ty])
{
book[tx][ty] = 1;
Que node;
node.x=tx;node.y=ty;node.change=false;
if(map[tx][ty] == map[t.x][t.y]) node.money = t.money;
else node.money = t.money+1;
que.push(node);
}
if(map[tx][ty] == -1 && !book[tx][ty])
{
Que node;
book[tx][ty] = 1;
node.x=tx;node.y=ty;node.change=true;
node.money = t.money+2;
map[tx][ty] = map[t.x][t.y];
que.push(node);
}
}
}
cout << ans << endl;
return 0;
}
错误代码:
#include <iostream>
using namespace std;
int map[105][105];
typedef struct
{
int x,y;
int money;
int color;
bool change;
}Que;
int m,n,next[4][2]={0,1,1,0,0,-1,-1,0};
int book[105][105]={0};
void init()
{
for(int i = 1;i <= m;++i)
for(int j = 1;j <= m;++j)
map[i][j] = -1;
}
int main() {
int head=0,tail=0;
Que que[100001];
cin>>m>>n;
init();
for(int i=0;i<n;i++){
int x,y,c;
cin>>x>>y>>c;
map[x][y]=c;
}
int ans = -1;
que[tail].x=1;que[tail].y=1;que[tail].change=false;que[tail++].money = 0;
book[1][1] = 1;
while(head < tail)
{
Que t = que[head++];
if(t.x == m && t.y == m)
{
if(ans < t.money)
ans = t.money;
}
for(int k = 0;k < 4;++k)
{
int tx = t.x+next[k][0];
int ty = t.y+next[k][1];
if(tx < 1 || ty < 1 || tx > m || ty > m) continue;
if(t.change && map[tx][ty] == -1) continue;
if(map[tx][ty] != -1 && !book[tx][ty])
{
book[tx][ty] = 1; //这里的标记会让最优路径的某些节点变成其它路径中节点
que[tail].x=tx;que[tail].y=ty;que[tail].change=false;
if(map[tx][ty]==map[t.x][t.y]) que[tail++].money = t.money;
else que[tail++].money = t.money+1;
}
if(map[tx][ty] == -1 && !book[tx][ty])
{
book[tx][ty] = 1;
que[tail].x=tx;que[tail].y=ty;que[tail].change=true;
que[tail++].money = t.money+2;
map[tx][ty] = map[t.x][t.y];
}
}
}
cout << ans << endl;
return 0;
}