HDU 1010(DFS,奇偶剪枝)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1010

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

题意:

问狗能不能在T时间那一时刻恰好到达D点。

思路:

因为问时刻,而非在时间段内,所以不能用BFS求最短路径。暴力搜索全部路径DFS,找到在T时刻能到达的所有点,看看是不是D点。需要剪枝不然会TLE。采用的剪枝方法是 奇偶剪枝法(链接传送门)

这里简单说下,就是到达某一点后判断该点到终点D的需要的最少时间(abs(x-ex)+abs(y-ey))和还剩的时间(T-s)的差是不是偶数。是奇数说明不可这条路是不可能的直接跳过。

AC代码:


#include <cstdio>
#include <queue>
#include <cstring>
#include <cmath>
using namespace std ;
int dxy[4][2] = {1,0,0,1,0,-1,-1,0};
char cs[10][10];
int val[10][10];
int n,m,T,flag;
int ex,ey ;
bool check( int x,int y )
{
    if( x<0 || y<0 || x>=n || y>=m || val[x][y] || cs[x][y]=='X' )
    return false;
    return true;
}

void dfs( int x, int y ,int s )
{
    if( s==T && cs[x][y] == 'D')
    {
        flag = 1;
        return ;
    }
    int tt = T - s - ( abs(x-ex)+abs(y-ey) );   // 剪枝否则超时
    if( tt<0 || tt&1 )
    return ;

    int tx,ty;
    for( int i=0; i<4; i++ )
    {
        tx = x + dxy[i][0] ;
        ty = y + dxy[i][1] ;
        if( check(tx,ty) )
        {
            val[tx][ty] = 1;
            dfs(tx,ty,s+1);
            val[tx][ty] = 0 ;
        }
        if(flag) return ;
    }
}


int main( )
{
    int sx,sy;
    while( ~scanf("%d%d%d",&n,&m,&T) )
    {
        if( !n && !m && !T ) break;

        for( int i=0; i<n; i++ )
        {
            scanf("%s",cs[i]);
            for( int j=0; j<m; j++ )
            {
               if( cs[i][j]=='S' )
               {
                   sx=i,sy=j;
               }
               else if( cs[i][j]=='D' )
               {
                   ex=i,ey=j;
               }
            }
        }

        memset(val,0,sizeof(val));
        val[sx][sy] = 1;
        flag = 0;
        dfs(sx,sy,0);
        if(!flag) printf("NO\n");
        else printf("YES\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值