1785: Problem A: Average Speed 求走了多远

Problem A: Average Speed

You have bought a car in order to drive from Waterloo to a big city. The odometer on their car is broken, so you cannot measure distance. But the speedometer and cruise control both work, so the car can maintain a constant speed which can be adjusted from time to time in response to speed limits, traffic jams, and border queues. You have a stopwatch and note the elapsed time every time the speed changes. From time to time you wonder, "how far have I come?". To solve this problem you must write a program to run on your laptop computer in the passenger seat.

Standard input contains several lines of input: Each speed change is indicated by a line specifying the elapsed time since the beginning of the trip (hh:mm:ss), followed by the new speed in km/h. Each query is indicated by a line containing the elapsed time. At the outset of the trip the car is stationary. Elapsed times are given in non-decreasing order and there is at most one speed change at any given time.

For each query in standard input, you should print a line giving the time and the distance travelled, in the format below.

Input

Output

Sample Input

00:00:01 100
00:15:01
00:30:01
01:00:01 50
03:00:01
03:00:05 140

Sample Output

00:15:01 25.00 km
00:30:01 50.00 km
03:00:01 200.00 km

HINT


给出我们时间和速度,让我们求出走了多远的距离  输入要注意
关于空格的的输入控制使用char ch = getchar(),同时它还作为了本题的一个是否输出的标识控制的条件
#include<bits/stdc++.h>
using namespace std;
int main()
{
	int h,m,s;
	double sum=0,nowv=0,nowtime=0,time=0;
	while(scanf("%d:%d:%d",&h,&m,&s)!=EOF)
	{
		char c;
		c=getchar();
		time=h*3600+m*60+s;
		if(c==' ')  //通过判断是否存在' '来判断速度是否变化 并输入 
		{
			int v;
			scanf("%d",&v);
			sum+=(time-nowtime)/3600*nowv; //先换成小时再乘以速度/每小时 
			nowtime=time;
			nowv=v;
		}
		else
		{
			printf("%02d:%02d:%02d",h,m,s);
			printf(" %.2f km\n",sum+(time-nowtime)/3600*nowv);
		 } 
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值