题目
1018 Public Bike Management (30分)
There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.
The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.
When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.
The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:
- PBMC -> S 1 S_1 S1 -> S 3 S_3 S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S 1 S_1 S1 and then take 5 bikes to S 3 S_3 S3, so that both stations will be in perfect conditions.
- PBMC -> S 2 S_2 S2 -> S 3 S_3 S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.
Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C m a x C_{max} Cmax (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S p S_p Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C i C_i Ci (i=1,⋯,N) where each C i C_i Ci is the current number of bikes at S i S_i Si respectively. Then M lines follow, each contains 3 numbers: S i S_i Si, S j S_j Sj, and T i j T_{ij} Tij which describe the time T i j T_{ij} Tij taken to move betwen stations S i S_i Si and S j S_j Sj. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−> S 1 S_1 S1−>⋯−> S p S_p Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S p S_p Sp is adjusted to perfect.
Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.
Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0
题目大意
一个站点的自行车容量达到最大容量的一半为最佳,多了的部分需要带回PBMC(公共自行车管理中心),少了则需要从PBMC带过去补给,现在给出最大容量Cmax,站点个数N,需要进行补给或者需要带回自行车的站点Sp,路的条数M;求:需要带去的自行车数量、到达目标站点的最短路径、需要带回的自行车数量;
如果最短路径长度相同则输出带去自行车数量最少的路径;
如果还是相同,则输出带回自行车最少的路径;
思路
- 最需要注意的是路只去不回!!!这意味着路径后面的站点如果有多余的自行车,是不能给前面的站点的(测试点5、7),毕竟都没到后面就不能给前面的站点。
使用Dijkstra算法获得到达某个站点最短路径的前一个站点的集合,用vector即可;
对于目标路径需要用到DFS回溯,从目标站点到PBMC,如果遇到了PBMC(0号站点),开始计算需要带去和带回的自行车数量,要从PBMC开始到目标站点,根据算得的两个值与已有的进行比较,满足更换条件则令路径为新的结果路径,保存在vector中之后倒着输出。
代码
#include<bits/stdc++.h>
using namespace std;
int Cmax, N, Sp, M, s1, s2, d, half;
int edge[510][510];
vector<int> hasBike;
vector<int> tmp, path;
vector<vector<int> > before;
int takeBack = INT_MAX, bringto = INT_MAX;
void dfs(int a){
tmp.push_back(a);
if(a == 0){ // 回溯到起点PBMC了
int t=0, b=0;
for(int i=tmp.size()-2; i>=0; i--){
//根据测试点5、7不通过,得知只能沿最短路径的方向收集多余的车,分给后面的结点,而后面的结点如果有多出来是不能返回给前面结点的,那么只能从PBMC出发。故修改下面已注释的代码
// if(hasBike[tmp[i]] < half) b += half - hasBike[tmp[i]];
// else t += hasBike[tmp[i]] - half;
if(hasBike[tmp[i]] > half){ // 需要带回
t += hasBike[tmp[i]] - half;
}else{ // 需要补给
int need = half - hasBike[tmp[i]];
if(t > need){
t -= need;
}else{
b += need - t;
t = 0;
}
}
}
if(bringto > b || (bringto == b && takeBack > t)){
path = tmp;
takeBack = t;
bringto = b;
}
tmp.pop_back();
return;
}else{
for(auto it : before[a])
dfs(it);
tmp.pop_back();
}
return;
}
int main(int argc, const char * argv[]) {
cin>>Cmax>>N>>Sp>>M;
half = Cmax/2;
hasBike.resize(N+1);
before.resize(N+1); // 记录该结点前一个结点
fill(edge[0], edge[0]+510*510, -1);
for(int i=1; i<=N; i++)
cin>>hasBike[i];
for(int i=0; i<M; i++){
cin>>s1>>s2>>d;
edge[s1][s2] = d;
edge[s2][s1] = d;
}
vector<int> dist(N+1, INT_MAX);
vector<bool> visit(N+1, false);
dist[0] = 0;
for(int i=0; i<=N; i++){
int u = -1, dis = INT_MAX;
for(int j=0; j<=N; j++){
if(!visit[j] && dist[j] < dis){
dis = dist[j];
u = j;
}
}
if(u == -1) break;
visit[u] = true;
for(int k=0; k<=N; k++){
if(!visit[k] && edge[u][k] != -1){
if(edge[u][k] + dist[u] < dist[k]){
dist[k] = edge[u][k] + dist[u];
before[k].clear();
before[k].push_back(u);
}else if(edge[u][k] + dist[u] == dist[k]){
before[k].push_back(u);
}
}
}
}
dfs(Sp);
printf("%d ", bringto);
for(int i=path.size()-1; i>=0; i--)
printf("%d%s", path[i], i==0?"" :"->");
printf(" %d", takeBack);
return 0;
}