PAT 甲级 1001 A+B Format (20分)

题目

1001 A+B Format (20分)

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where − 1 0 6 ​ ​ ≤ a , b ≤ 1 0 6 −10^6​​ ≤a,b≤10^6 106a,b106. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

思路

利用字符串得到 a + b a+b a+b的绝对值,如果是负数先输出负号;记字符串长度为 l e n s lens lens,先得到其对3取余的数 i i i(若余数为0则 i = 3 i=3 i=3)作为起始输出部分 s . s u b s t r ( 0 , i ) s.substr(0,i) s.substr(0,i);之后利用for循环每三个字符作为字串输出以及“,”输出。

代码

#include <bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int a, b, c;
    cin>>a>>b;
    string s;
    c = a+b;
    if(c < 0) cout<<"-";
    s = to_string(abs(c));
    int i = s.size() % 3 == 0 ? 3 : s.size() % 3;
    cout<<s.substr(0, i);
    for(i; i<s.size(); i+=3)
        cout<<","<<s.substr(i,3);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值