PAT 甲级 1012 The Best Rank (25分)

题目

1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N N N and M M M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N N N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

题目大意

给出N位学生的学号和各科成绩,再给出需要查询的M位学生的学号,给出每位学生排名最高的课程(或平均分)的名次和课程名,若所查询的学生号码不在给定的N个学号中,则输出N/A。

思路

有四门的成绩需要比较,则需要四组 学生-成绩,每组进行排序,同时排序得到的名次若分数相同则名次相同,例如 排名为 1,2,2,4,5,而非1,2,2,3,4。
利用map<int, int[4] >存储学号和各科成绩,按照ACME的顺序存储,这样可以根据最高名次的下标从字符串“ACME”中得到最高名次对应的科目。

代码

#include<bits/stdc++.h>
using namespace std;

typedef pair<int,double> stu;
vector<stu> id_score[4];
map<int, int[4] > rankList;

bool cmp(const stu& a, const stu& b){
    return a.second == b.second ? a.first < b.first : a.second > b.second;
}

void get_rank(int N){
    for(int i=0; i<4; i++){
        int r = 0;
        for(int j=0; j<N; j++){
            if(j != 0 && id_score[i][j].second == id_score[i][j-1].second)
                rankList[id_score[i][j].first][i] = r;
            else{
                rankList[id_score[i][j].first][i] = j+1;
                r = j+1;
            }
        }
    }
}

int main(){
    int N, M;
    double id, c, m, e, ave;
    cin>>N>>M;
    for(int i=0; i<N; i++){
        cin>>id>>c>>m>>e;
        ave = (c+m+e) / 3;
        id_score[1].push_back({id, c});
        id_score[2].push_back({id, m});
        id_score[3].push_back({id, e});
        id_score[0].push_back({id, ave});
    }
    for(int i=0; i<4; i++)
        sort(id_score[i].begin(), id_score[i].end(), cmp);
    get_rank(N);
    string priority = "ACME";
    for(int i=0; i<M; i++){
        cin>>id;
        if(rankList.count(id)){
            int pos = min_element(rankList[id], rankList[id] + 4) - rankList[id];
            printf("%d %c\n", rankList[id][pos], priority[pos]);
        }else{
            printf("N/A\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值