PAT 甲级 1053 Path of Equal Weight (30分)

题目

1053 Path of Equal Weight (30分)

Given a non-empty tree with root R, and with weight W**i assigned to each tree node T**i. The weight of a path from *R* to *L* is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

img

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where W**i (<1000) corresponds to the tree node T**i. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence { A 1 , A 2 , ⋯ , A n A_1,A_2,⋯,A_n A1,A2,,An} is said to be greater than sequence { B 1 , B 2 , ⋯ , B m B_1,B_2,⋯,B_m B1,B2,,Bm} if there exists 1≤k< min ⁡ { n , m } \min \{n,m\} min{n,m} such that A i = B i A_i=B_i Ai=Bi for i=1,⋯,k, and A k A_k Ak+1> B k B_k Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题目大意

给出一棵非空的树,根结点ID为00, 每个结点都有其权重, 根结点为R, 从R到叶子结点L的路径的权重等于路径上的所有点的权重之和;
输入:给出树的结点个数N, 非叶子结点个数M,表示权重之和的数S,接下来一行N个数表示每个结点的权重,接下来M行每行给出非叶子结点的id, 孩子个数,孩子id,
要求:找到所有路径,使得每条路径权重之和为S,输出根结点到叶子结点的路径的权重序列,按权重序列降序输出

思路

因为要求每条路径的排列为按结点权重降序输出,故可以在刚开始的时候对父结点的子结点序列按权重降序排序,利用DFS来找路径即可

代码

#include<bits/stdc++.h>
using namespace std;
struct node{
    int id, weight;
};

vector<int> weight;
vector<vector<node> > tree;
vector<int> path;
vector<vector<int> > allPaths;
int N, M, S, K, id, child;

void dfs(int v){
    path.push_back(v);
    if(tree[v].size() == 0){ // 叶子结点
        int sum = 0;
        for(int i=0; i<path.size(); i++){
            sum += weight[path[i]];
        }
        if(sum == S){
            allPaths.push_back(path);
        }
        path.pop_back();
        return;
    }
    for(auto it : tree[v])
        dfs(it.id);
    path.pop_back();
}
int main(int argc, const char * argv[]) {
    scanf("%d%d%d",&N, &M, &S);
    weight.resize(N);
    tree.resize(N);
    for(int i=0; i<N; i++)
        cin>>weight[i];
    for(int i=0; i<M; i++){
        scanf("%d%d",&id, &K);
        for(int j=0; j<K; j++){
            scanf("%d", &child);
            tree[id].push_back({child, weight[child]});
        }
        sort(tree[id].begin(), tree[id].end(), [](const node& a, const node& b){
            return a.weight > b.weight;
        });
    }
    dfs(0);
    for(int i=0; i<allPaths.size(); i++){
        for(int j=0; j<allPaths[i].size(); j++)
            printf("%s%d", j==0 ? "" : " ", weight[allPaths[i][j]]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值