PAT 甲级 1051 Pop Sequence (25分)

题目

1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目大意

给出一个容量为M的栈, 将1-N按顺序输入栈中 并且 随机pop;
给出一个数字序列,请你判断该序列是否可能是一组随机pop出来的数字组成的序列

思路

每次接受一个序列,用栈来进行push和pop,每次遇到和栈顶相同的数字则输出直到不相等或者栈空,因为有最大容量M的限制,所以每次push之后要对容量进行检测判断;

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int M, N, K;
    scanf("%d%d%d", &M, &N, &K);
    for(int i=0; i<K; i++){
        stack<int> s;
        int seq[N];
        bool flag = true;
        for(int j=0; j<N; j++)
            scanf("%d", &seq[j]);
        int st = 0;
        for(int j=1; j<=N && flag; j++){
            s.push(j);
            if(s.size() > M) flag = false;
            while(!s.empty() && s.top() == seq[st] && st<N){
                s.pop();
                st++;
            }
        }
        if(flag == false || !s.empty()) printf("NO\n");
        else printf("YES\n");
        
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值