PAT 甲级 1023 Have Fun with Numbers (20分)

题目

1023 Have Fun with Numbers (20分)

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

题目大意

检查给出的数字的两倍是不是由只原来数字中所有的数字排列组成的,不能多不能少

思路

用一个数组记录原来数字中各个数字出现的次数,每遍历到一个就加一,然后两倍的数字也进行遍历,每遍历到一个就减一;最后遍历如果有某个位置的值不为0则输出No,反之Yes,换行输出两倍数字的结果。

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int count[10] = {0};
    string s, r="";
    int jin = 0, left, cal;
    cin>>s;
    for(int i=s.size()-1; i>=0; i--){
        count[s[i]-'0']++;
        cal = 2 * (s[i] - '0') + jin;
        left =  cal % 10;
        jin = cal / 10;
        r += left + '0';
        count[left]--;
    }
    if(jin > 0){
        r += jin + '0';
        count[jin]--; 
    }
    reverse(r.begin(), r.end());  // r需要翻转
    for(int i=0; i<10; i++)
        if(count[i] != 0){
            printf("No\n%s", r.c_str());
            return 0;
        }
    printf("Yes\n%s", r.c_str());
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值