PAT 甲级 1048 Find Coins (25分)

题目

1048 Find Coins (25分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤105, the total number of coins) and M (≤103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1+V2=M and V1≤V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output No Solution instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

题目大意

只能使用两个硬币来付钱的情况下,
输入:硬币个数N和需要付的钱M, 接下来N个硬币的值
能用两个硬币付正好的钱则输出两个硬币的值,若结果不唯一则输出包含最小的硬币的情况;
不能则输出No Solution

思路

将输入的硬币价值放入vector
第一次遍历,利用数组记录不同价值硬币的个数;
第二次遍历,判断 价值为 M - 当前硬币价值 的硬币数量是否大于0,这里需要注意两枚相同价值硬币 相加等于 M的情况;

代码

#include<bits/stdc++.h>
using namespace std;
int main(int argc, const char * argv[]) {
    int N, M, cnt[100010]={0};
    bool flag = true;
    scanf("%d%d",&N, &M);
    vector<int> v(N);
    for(int i=0; i<N; i++){
        scanf("%d", &v[i]);
        cnt[v[i]]++;
    }
    sort(v.begin(), v.end());
    for(int i=0; i<N; i++){
        if(M - v[i] <= 0) break;
        if((M == 2*v[i] && cnt[v[i]] >= 2) || (M != 2*v[i] && cnt[M - v[i]] > 0)){
            flag = false;
            printf("%d %d",v[i], M-v[i]);
            break;
        }
    }
    if(flag) printf("No Solution");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值