1014 Waiting in Line (30分)【queue队列】

1014 Waiting in Line (30分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 customers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

解题思路:

首先来说一下,这道题真的是非常需要耐心。

很明显这是一道队列的模拟题,用队列来模拟银行的服务过程。银行共有n个窗口,其中每个窗口有m个容量,有k个客户,并且最后会有q个查询,询问你对应编号客户的完成时间。

 然后需要注意的就是:

1.客户是挑当前人数少的队伍进入,如果多个窗口有最少人数,则优先进入编号小的窗口。

2.只要是在17:00开始办理的服务,不论时长多少,哪怕超过了17:00也能办完!!!

3.注意测试样例中没有n或m为0的情况!

然后我竟然卡了好久没AC的原因是“Sorry”而不是“sorry”

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<queue>
using namespace std;
#define MAXN 0xffffff

queue<pair<int,int>>que[30];  //队列,模拟每个窗口,其中p.first代表客户处理时间,p.second代表客户编号
int cost[1010] = { 0 };  //存储每个客户所花费的时间,以分钟为单位,0代表未能完成

int main()
{
	int n, m, k, q;
	cin >> n >> m >> k >> q;
	int cnt = 1;
	//先入队
	for (int i = 0; i < m&&cnt <= k; i++)
	{
		for (int j = 0; j < n&&cnt <= k; j++)
		{
			int time;
			cin >> time;
			que[j].push(pair<int, int>(time, cnt));
			cnt++;
		}
	}

	queue<pair<int, int>>wait;  //用来保存还没入队的人
	while (cnt <= k)
	{
		int time;
		cin >> time;
		wait.push(pair<int, int>(time, cnt));
		cnt++;
	}
	int costtime = 0;
	for (int i = 1; i <= k;)
	{
		int mint = MAXN;
		for (int j = 0; j < n; j++)
		{
			if (!que[j].empty() && que[j].front().first < mint)
				mint = que[j].front().first;
		}
		
		if (costtime + mint >= 540)  //如果当前时间已经到了17:00,则服务完还在窗口的人
		{
			for (int j = 0; j < n; j++)
			{
				if (que[j].size() != 0)
					cost[que[j].front().second] = costtime + que[j].front().first;
			}
			break;
		}
		costtime = costtime + mint;
		//然后把所有在队头的人的时间减去最小时间
		//同时如果有剩余时间为0的人则出队,并把在等待的人补入
		for (int j = 0; j < n; j++)
		{
			if (!que[j].empty())
			{
				que[j].front().first -= mint;
				if (que[j].front().first == 0)
				{
					cost[que[j].front().second] = costtime;
					que[j].pop();
					if (!wait.empty())
					{
						que[j].push(wait.front());
						wait.pop();
					}
					i++;
				}
			}
		}
	}
	for (int i = 0; i < q; i++)
	{
		int qus;
		cin >> qus;
		if (cost[qus] == 0)
			cout << "Sorry" << endl;
		else
		{
			int min = cost[qus] % 60;
			int hour = cost[qus] / 60+8;
			if (hour < 10)
				cout << "0" << hour << ":";
			else cout << hour << ":";
			if (min < 10)
				cout << "0" << min << endl;
			else cout << min << endl;
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

胡小涛

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值