PAT A1045:Favorite Color Stripe之动态规划

题目描述

1045 Favorite Color Stripe (30分)
Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva’s favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva’s favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (≤200) followed by M Eva’s favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (≤10^4 ) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line a separated by a space.

Output Specification:
For each test case, simply print in a line the maximum length of Eva’s favorite stripe.

Sample Input:

6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

求解思路

题意:给定颜色种类的数目n,Eva喜欢的颜色数目m,以及按序给定Eva喜欢的颜色种类,然后给定长度为L的颜色序列,要求我们给出按照Eva喜欢颜色的优先级排序拼接得到的最长颜色序列的长度。
求解:

  • 使用一个哈希表hashTable,索引为Eva喜欢的颜色,值为Eva喜欢的颜色的优先级
  • 在输入颜色序列的时候,筛选掉Eva不喜欢的颜色,如果当前颜色为Eva喜欢的颜色,则保存该颜色的优先级放入到数组a中。
  • 从0~cnt开始遍历数组a,对于第i个元素,从0到i-1遍历,如果找到j所对应颜色的优先级小于等于i所对应颜色的优先级,那么则判断是否更新dp[i],dp[i]=max(dp[i],dp[j]+1),每次遍历数组a的时候都需要判断是否更新得到的最大序列长度。

实现代码(AC)

#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn1=201;
const int maxn2=10001;
int n,m,l;
int cnt=0,ans=-1;
int hashTable[maxn1];
int a[maxn2],dp[maxn2];
void solve()
{
	fill(hashTable,hashTable+maxn1,0);
	scanf("%d",&n);
	scanf("%d",&m);
	for(int i=1;i<=m;i++)
	{
		int x;
		scanf("%d",&x);
		hashTable[x]=i;
	}
	scanf("%d",&l);
	for(int i=0;i<l;i++)
	{
		int x;
		scanf("%d",&x);
		if(hashTable[x]>0)
			a[cnt++]=hashTable[x];
	}
	for(int i=0;i<cnt;i++)
	{
		dp[i]=1;
		for(int j=0;j<i;j++)
		{
			if(a[j]<=a[i]&&dp[i]<dp[j]+1)
				dp[i]=dp[j]+1;
		}
		ans=max(ans,dp[i]);
	}
	printf("%d",ans);
}
int main()
{
	solve();
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值