PAT (Advanced Level) -1105 Spiral Matrix

1105 Spiral Matrix(25 分)

PAT (Basic Level)-1050 螺旋矩阵(25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where mand n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains Npositive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

先处理下N 求出满足条件的m和n 排序,再每个方向把数字存进去 最后打印

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
using namespace std;

int main()
{
	int N,i,j;
	cin>>N;
	int *a=new int[N];
	for(int i=0;i<N;i++)scanf("%d",&a[i]);
	sort(a,a+N,greater<int>());
	int m,n,min=9999;
	for(i=1;i<=N;i++)
	{
		for(j=1;j<=i;j++)
		{
			if(i*j==N&&i-j<min)
			{
				min=i-j;
				m=i;
				n=j;
				break;
			}
		}
	}
	vector<vector<int> >res(m,vector<int>(n));	
	int cnt=0,c=0;
	while(cnt<N)
	{
		for(i=c,j=c;j<n-c;j++)
		{
			if(cnt>=N)break;
			res[i][j]=a[cnt++];
		}
		for(j--,i++;i<m-c;i++)
		{
			if(cnt>=N)break;
			res[i][j]=a[cnt++];
		}
		for(i--,j--;j>=c;j--)
		{
			if(cnt>=N)break;
			res[i][j]=a[cnt++];
		}
		for(i--,j++;i>c;i--)
		{
			if(cnt>=N)break;
			res[i][j]=a[cnt++];
		}
		c++;
	}
	for(i=0;i<m;i++)
	{
		for(j=0;j<n-1;j++)
		{
			printf("%d ",res[i][j]);
		}
		printf("%d\n",res[i][n-1]);
	}
	
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值