PAT (Advanced Level) 1105 Spiral Matrix (25 分)

1105 Spiral Matrix (25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

Code:

#include <iostream>
#include <vector>
#include <algorithm>
#include <cmath>
#pragma warning(disable:4996)
using namespace std;
int main()
{
	int n;
	scanf("%d", &n);
	vector<int> vec(n);
	for (int i = 0; i < n; i++)
		scanf("%d", &vec[i]);
	sort(vec.begin(), vec.end(), [](const int n1, const int n2) {return n1 > n2; });
	int col = sqrt(n), row;
	while (n % col != 0) col--;
	row = n / col;
	vector<vector<int>> matrix(row, vector<int>(col));
	int level = row / 2 + row % 2;
	int t = 0;
	for (int i = 0; i < level; i++) {
		for (int j = i; j <= col - 1 - i && t <= n - 1; j++)
			matrix[i][j] = vec[t++];
		for (int j = i + 1; j <= row - 2 - i && t <= n - 1; j++)
			matrix[j][col - 1 - i] = vec[t++];
		for (int j = col - i - 1; j >= i && t <= n - 1; j--)
			matrix[row - 1 - i][j] = vec[t++];
		for (int j = row - 2 - i; j >= i + 1 && t <= n - 1; j--)
			matrix[j][i] = vec[t++];
	}
	for (int i = 0; i < matrix.size(); i++)
		for (int j = 0; j < matrix[i].size(); j++)
			printf("%d%c", matrix[i][j], (j == matrix[i].size() - 1 ? '\n' : ' '));
	return 0;
}

思路:

https://blog.csdn.net/liuchuo/article/details/52123228

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值