1023. Have Fun with Numbers (20)(C++)

 

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

 

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

 

Input Specification:

 

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

 

Output Specification:

 

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

Sample Output:

Yes
2469135798

回过头看到自己之前写的代码,我当时一定在学堆栈(哈哈哈哈哈哈)其实字符串就可以直接处理了,用long long也可以的。思想都是一样的。

#include <iostream>
#include <string> 
#include <algorithm>
using namespace std;
int visit[10], c = 0, temp;
bool flag = true;
int main(){
	string s, ans;
	cin>>s;
	for(int i = s.length() - 1; i >= 0; -- i){
		++ visit[s[i] - '0'];
		temp = c + ((s[i] - '0') << 1) ;
		ans += (temp % 10) + '0';
		c = temp/ 10;
	}
	if(c == 1)
		ans += '1';
	reverse(ans.begin(), ans.end());
	for(int i = 0; i < ans.length(); ++ i)
		if(-- visit[ans[i] - '0'] < 0)
			flag = false;
	printf("%s\n%s", flag == true ? "Yes" : "No", ans.c_str());
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值