1095 Cars on Campus (30 point(s))(C++)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and outat the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

解题思路:模拟题,某些思路很想phone bills那道题,将所有的记录存储,其中时间以秒为单位,为距离00:00: 00已经过去多少秒,flag记录状态,flag = 0 则该记录为in,flag = 1,则该记录为out, 然后将所有记录按秒排序,接着遍历所有记录,本次遍历的任务为记录每个车的有效总时长,同时将无效记录的flag设为-1,在遍历过程中对每一辆车,存在四种可能(用laststats记录该车的上一个记录的状态)

①上一个该车的记录状态为0,现在也是0:上一个状态无效

②上一个该车的记录状态为0,现在为1:两个记录均有效,计算相隔时间,同时更新laststats

③上一个该车的记录状态为1,现在也是1:该记录无效

④上一个该车的记录状态为1,现在是0:更新laststats

注意点:如果某个车的最后一个记录的状态为in,则该记录也是无效的。

#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
#include <map>
using namespace std;
int n, k, cnt = 0, cur = 0, maxn = 0, num = 0;
typedef struct{
	string name;
	int id, time, flag;
}record;
int main(){
	scanf("%d %d\n", &n, &k);
	vector<record>records(n);
	map<string, int>m;
	for(int i = 0; i < n; ++ i){
		cin >> records[i].name;
		if(m[records[i].name] == 0)
			m[records[i].name] = ++ cnt;
		int hh, mm, ss;
		char op[5];
		scanf("%d:%d:%d %s\n", &hh, &mm, &ss, op);
		records[i].id = m[records[i].name];
		records[i].time = 3600 * hh + 60 * mm + ss;
		records[i].flag = (op[0] == 'i' ? 0 : 1);
	}
	sort(records.begin(), records.end(), [](record a, record b){return a. time < b. time;});
	vector<int>sum(cnt + 1, 0), laststats(cnt + 1, 1), lastindex(cnt + 1, -1);
	vector<string>ans;
	for(int i = 0; i < n; ++ i){
		int tempid = records[i].id;
		if(laststats[tempid] == 0 && records[i].flag == 0){
			records[lastindex[tempid]].flag = -1;
			lastindex[tempid] = i;
		}
		else if(laststats[tempid] == 0){
			sum[tempid] += (records[i].time - records[lastindex[tempid]].time);
			if(sum[tempid] > maxn){
				ans.clear();
				ans.push_back(records[i].name);
				maxn = sum[tempid];
			}
			else if(sum[tempid] == maxn)
				ans.push_back(records[i].name);
			lastindex[tempid] = i;
			laststats[tempid] = 1;
		}
		else if(laststats[tempid] == 1 && records[i].flag == 1)
			records[i].flag = -1;
		else if(laststats[tempid] == 1){
			lastindex[tempid] = i;
			laststats[tempid] = 0;
		}
	}
	for(int i = 1; i <= cnt; ++ i)
		if(laststats[i] == 0)
			records[lastindex[i]].flag = -1; 
	for(int i = 0; i < k; ++ i){
		int hh, mm, ss, temptime;
		scanf("%d:%d:%d", &hh, &mm, &ss);
		temptime = 3600 * hh + 60 * mm + ss;
		while(cur < n && records[cur].time <= temptime){
			if(records[cur].flag == 0)
				++ num;
			else if(records[cur].flag == 1)
				-- num;
			++ cur;
		}
		printf("%d\n", num);
	}
	sort(ans.begin(), ans.end(), less<string>());
	for(int i = 0; i < ans.size(); ++ i)
		printf("%s ", ans[i].c_str());
	printf("%02d:%02d:%02d", maxn / 3600, (maxn % 3600) / 60, maxn % 60);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
自动驾驶车辆的身体视觉和行为是指车辆通过感知和行动来自主地驾驶。这个概念是为了解决自动驾驶车辆在交通路况、人行横穿等复杂情况下的感知和决策问题。通过车辆感知传感器,如摄像头、激光雷达和超声波传感器等,自动驾驶系统可以实时获取周围环境的信息。然后,通过深度学习和图像处理技术,系统可以将传感器数据转化为可理解和处理的场景信息,如道路、车辆、行人和障碍物等。 基于感知信息,自动驾驶车辆需要做出决策和行动。这涉及到对不同情况的判断和预测,如车辆是否需要加速、刹车或转向等。同时,自动驾驶车辆还需要具备与其他交通参与者的协调能力,如保持安全距离、按照交通规则行驶等。 为了实现自动驾驶车辆的“身体视觉和行为”,需要综合运用计算机视觉、机器学习、人工智能和控制理论等多学科的知识。此外,还需要建立高精度的地图和定位系统,以确保车辆准确地感知和理解周围环境。同时,由于自动驾驶技术的安全性和可靠性至关重要,还需要对系统进行严格的测试和验证,以确保其在各种场景下都能正确地做出决策和行动。 总而言之,自动驾驶车辆的身体视觉和行为是为了实现车辆自主地感知和响应周围环境,以实现安全、高效、智能的自动驾驶。在未来,随着技术的不断进步,自动驾驶车辆将能够更好地理解和适应各种复杂的道路场景,为人们的出行带来更多的便利与安全。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值