G - coprime sequence ---------HDU 6025

Do you know what is called ``Coprime Sequence''? That is a sequence consists of nnpositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

Input

The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

Sample Output

1
2
2

题目分析:就是先给你一个数串,这个数串中的每个数相互之间的最大公约数是1,现在让你删去一个数,从而使这他的公约数最大,那么解法就是,一个简单的枚举把所有的情况全部枚举一遍,放心不会超时

#include<iostream>
#include<cstdio>
#include<algorithm>

using namespace std;
const int maxn=1e5;

int gcd(int a,int b)
{
    return  b==0? a:gcd(b,a%b);
}

int main()
{
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        int a[maxn+10];
        int fro[maxn+10];
        int beh[maxn+10];
        cin>>n;
        for(int i=0;i<n;i++) cin>>a[i];
        fro[0]=a[0];
        for(int i=1;i<n;i++)
        {
            fro[i]=gcd(fro[i-1],a[i]);
        }
        beh[n-1]=a[n-1];//求倒序时的公约数,
        for(int i=n-2;i>=0;i--)
        {
            beh[i]=gcd(beh[i+1],a[i]);
        }
        int ans=0;
        for(int i=0;i<n;i++)//在删去某一个数的时候,这个数串会被分成两部分,那么去计算这两部分的最大公约数,然后去求这两个公约数的最大公约数,再和之前求得的公约数进行比较;
        {
            if(i==0)
            {
                ans=beh[1];
            }
            else if(i==n-1)
            {
                ans=max(ans,fro[n-2]);
            }
            else{
                ans=max(ans,gcd(fro[i-1],beh[i+1]));
            }
        }
        printf("%d\n",ans);
    }
    return  0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值