G - coprime sequence (HDU-6025+前缀GCD+后缀GCD)

Do you know what is called ``Coprime Sequence''? That is a sequence consists of nnpositive integers, and the GCD (Greatest Common Divisor) of them is equal to 1. 
``Coprime Sequence'' is easy to find because of its restriction. But we can try to maximize the GCD of these integers by removing exactly one integer. Now given a sequence, please maximize the GCD of its elements.

 

Input

The first line of the input contains an integer T(1≤T≤10)T(1≤T≤10), denoting the number of test cases. 
In each test case, there is an integer n(3≤n≤100000)n(3≤n≤100000) in the first line, denoting the number of integers in the sequence. 
Then the following line consists of nn integers a1,a2,...,an(1≤ai≤109)a1,a2,...,an(1≤ai≤109), denoting the elements in the sequence.

 

Output

For each test case, print a single line containing a single integer, denoting the maximum GCD.

 

Sample Input

3
3
1 1 1
5
2 2 2 3 2
4
1 2 4 8

 

 

Sample Output

1
2
2

 题意:给你一个数列,去掉一个数,是剩下的数列的最大公约数最大;

解题思路:求一个数列的最大公约数我们可以先求前两个数的最大公约数,然后用所求的最大公约数与第三个数求最大公约数,就这样一直GCD到最后一个数,求得的最大公约数即为数列的最大公约数,因为数列的最大公约数与所求顺序无关,只要将所有前面所求的GCD与后面的数进行GCD,最后的GCD即为数列的最大公约数,所以当去掉第i个元素时,我们只需要求gcd(left[i-1],right[i+1])就行。代码中的ans初始化为第一个数和最后一个数的最大公约数的最大值,以方便后面的循环

AC代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int MAXN=1e5+10;
int gcd(int a,int b)
{
	return b?gcd(b,a%b):a;
}
int main()
{
	int a[MAXN],left[MAXN],right[MAXN];//left[]数组储存从左到右的gcd,right[]数组储存从右到左
                                        //的gcd,left[i]表示数列中0-i个数的最大公约数
                                        //right[i]表示i以后所有数的最大公约数
	int t,n,ans;
	cin>>t;
	while(t--)
	{
		cin>>n;
		for(int i=0;i<n;i++)
		cin>>a[i];
		left[0]=a[0];
		for(int i=1;i<n;i++)
			left[i]=gcd(left[i-1],a[i]);
		right[n-1]=a[n-1];
		for(int i=n-2;i>=0;i--)
			right[i]=gcd(right[i+1],a[i]);
		ans=max(left[n-2],right[1]);
		for(int i=1;i<n-1;i++)
			ans=max(ans,gcd(left[i-1],right[i+1]));
		cout<<ans<<endl;
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值