FatMouse's Speed (最长上升子序列 + 路径输出)

FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing. 

Input

Input contains data for a bunch of mice, one mouse per line, terminated by end of file. 

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice. 

Two mice may have the same weight, the same speed, or even the same weight and speed. 

Output

Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]] 

and 

S[m[1]] > S[m[2]] > ... > S[m[n]] 

In order for the answer to be correct, n should be as large as possible. 
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 

Sample Input

6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output

4
4
5
9
7

题意:第一列是第 i 个老鼠的重量,第二列是第 i 个老鼠的速度,求满足第一个升序,第二个数组降序的最多老鼠数量。

思路:因为每个老鼠是的重量和速度是一定的,那么我们可以把这两个参数以及这个老鼠的位置存放在结构体里,对老鼠的速度降序排列,然后我们再求最长上升子序列。最后就是找路径了,因为最长的长度都是分布在dp数组后面的,因此我们可以从后往前遍历,我们可以开一个二维数组,用来存放每个长度的最大重量,以及这个老鼠的位置。如果遇到相同的长度,就要取重量最大的放在这,这样才能保证数据最优,同时任何一个长度的最大重量不能大于它后面一个长度的最大重量,因此我们可以把最大长度的后一位重量设为无穷大。然后从最后一位向前更新,最后输出每个老鼠的位置即可。

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1010];
struct node
{
    int a,b,c;
}list[1010];
bool cmp(node xx,node yy)
{
    if(xx.b==yy.b)
        return xx.a<yy.a;
    else
        return xx.b>yy.b;
}
struct note
{
    int x,y;
}num[1010];
int main()
{
    int i,j,k=0;
    while(~scanf("%d%d",&list[k].a,&list[k].b))
        list[k].c=k+1,k++;
    int maxx=0;
    sort(list,list+k,cmp);//对速度降序排序
    memset(dp,0,sizeof(dp));
    for(i=0;i<k;i++)   //找重量的最长上升子序列
    {
        dp[i]=1;
        for(j=0;j<i;j++)
        {
            if(list[i].a>list[j].a)
            {
                dp[i]=max(dp[i],dp[j]+1);
            }

        }
       // printf("****%d\n",dp[i]);
        if(maxx<dp[i])  //最长长度
        {
            maxx=dp[i];
        }
        num[i].x=0;  //初始化
    }
    num[maxx+1].x=0x3f3f3f3f;  //最大长度的最后一位设为无穷大
    printf("%d\n",maxx);
    for(i=k-1;i>=0;i--)
    {
        if(list[i].a<num[dp[i]+1].x)  //如果这个长度的重量小于下一个长度下的重量,才能满足题意
        {
            if(list[i].a>num[dp[i]].x)  //更新最大值,且保存老鼠的位置
            {
                num[dp[i]].x=list[i].a;
                num[dp[i]].y=list[i].c;
            }
        }
    }
    for(i=1;i<=maxx;i++)  //输出
       printf("%d\n",num[i].y);

}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值