1114 Family Property (25 分)

This time, you are supposed to help us collect the data for family-owned property. Given each person's family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:

ID Father Mother k Child​1​​⋯Child​k​​ M​estate​​ Area

where ID is a unique 4-digit identification number for each person; Father and Mother are the ID's of this person's parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child​i​​'s are the ID's of his/her children; M​estate​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.

Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:

ID M AVG​sets​​ AVG​area​​

where ID is the smallest ID in the family; M is the total number of family members; AVG​sets​​ is the average number of sets of their real estate; and AVG​area​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID's if there is a tie.

Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100

Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
int n;
struct Data {
	int id, fid, mid, k;
	int cid[6];
	int en, a;
}dat[10100];
bool visited[10010] = { 0 };
int father[10010];
struct Node {
	int id, people = 0;
	int enm, area;
	double avere, avera;
}ans[10010];
int findroot(int x) {
	while (father[x] != x) {
		x = father[x];
	}
	return x;
}
void uni(int a, int b) {
	int faA = findroot(a), faB = findroot(b);
	if (faA > faB) father[faA] = faB;
	else if (faA < faB) father[faB] = faA;
}
int cnt = 0;
bool cmp(Node x, Node y) {
	if (x.avera != y.avera) return x.avera > y.avera;
	else return x.id < y.id;
}
int main() {
	cin >> n;
	for (int i = 0; i < 10010; i++) {
		father[i] = i;
	}
	for (int i = 0; i < n; i++) {
		int ti;
		scanf("%d", &ti);
		dat[ti].id = ti;
		scanf("%d%d%d", &dat[ti].fid, &dat[ti].mid, &dat[ti].k);
		visited[ti] = 1;
		if (dat[ti].fid != -1) {
			visited[dat[ti].fid] = 1;
			uni(ti, dat[ti].fid);
		}
		if (dat[ti].mid != -1) {
			visited[dat[ti].mid] = 1;
			uni(ti, dat[ti].mid);
		}
		for (int j = 0; j < dat[ti].k; j++) {
			scanf("%d", &dat[ti].cid[j]);
			visited[dat[ti].cid[j]] = 1;
			uni(ti, dat[ti].cid[j]);
		}
		scanf("%d%d", &dat[ti].en, &dat[ti].a);
	}
	for (int i = 0; i < 10010; i++) {
		if (visited[i] == 1) {
			int fa = findroot(i);
			ans[fa].id = fa;
			ans[fa].people++;
			ans[fa].enm += dat[i].en;
			ans[fa].area += dat[i].a;
		}
	}
	for (int i = 0; i < 10010; i++) {
		if (ans[i].people > 0) { 
			cnt++;
			ans[i].avere = (double)ans[i].enm / ans[i].people;
			ans[i].avera = (double)ans[i].area / ans[i].people;
		}
	}
	sort(ans, ans + 10010, cmp);
	printf("%d\n", cnt);
	for (int i = 0; i < cnt; i++) {
		printf("%04d %d %.3lf %.3lf\n", ans[i].id, ans[i].people, ans[i].avere, ans[i].avera);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值